Bug 85891 - Symbols too small in Formulas
Summary: Symbols too small in Formulas
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: noRepro:4.4.0.0alpha2+:Linux noRepro:...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-05 05:46 UTC by Peter Schneider
Modified: 2015-11-08 14:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
SCreenshot showing the bug (25.83 KB, image/png)
2014-11-06 05:36 UTC, Peter Schneider
Details
same example as OP but using alternate font Garmond Pro (31.29 KB, image/png)
2014-11-06 06:28 UTC, V Stuart Foote
Details
same formula of OP with Liberation Serif -- noRepro (51.20 KB, image/png)
2014-11-17 00:05 UTC, V Stuart Foote
Details
Sample math document with formula (5.47 KB, application/vnd.oasis.opendocument.formula)
2014-11-17 00:06 UTC, V Stuart Foote
Details
noRepro 4.2.6.3 on Linux (32-bit Fedora 20, LXDE en-US) (152.89 KB, image/jpeg)
2014-11-17 16:17 UTC, V Stuart Foote
Details
noRepro 4.4.0alpha2+ on Linux (32-bit Fedora 20, LXDE en-US) (169.58 KB, image/jpeg)
2014-11-17 16:18 UTC, V Stuart Foote
Details
no repro 5.0.0.0.beta1 Linux (64-bit Xubuntu de-DE) (110.87 KB, image/png)
2015-06-09 14:27 UTC, Arnaud LE CAM
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Schneider 2014-11-05 05:46:16 UTC
To reproduce enter within a formula within libreoffice writer
{}={}neq{}
you will notice that the not equals has only half the size than the equals symbol.
The not equals should have the same size. The resulting mathematic formulas just look strange.
This effect exists since the fonts have been exchanged with the libre fonts.

This problem also happens with from and to command. The limit bound are to small as well, making them nearly unreadable.

Same for:
%winkel (probably %angle in the english version)
Comment 1 V Stuart Foote 2014-11-05 23:59:48 UTC
Any better result if you prepare the formula first in Math--setting your fonts and scale there, and then insert as OLE object into Writer?
Comment 2 Peter Schneider 2014-11-06 05:36:13 UTC
Created attachment 109008 [details]
SCreenshot showing the bug
Comment 3 V Stuart Foote 2014-11-06 06:28:21 UTC
Created attachment 109011 [details]
same example as OP but using alternate font Garmond Pro

@Peter,

The default font across LibreOffice is Liberation Serif, and that has some odd spacing.  However, the font foundry can be simply changed to something more appealing.

Attached is your example but now rendered with Adobe Garamond Pro, more aesthetically pleasing.  But the point is you can change to any font on your system that you prefer.

In Math that is done from the Format --> Fonts dialog, and select the Modify drop down. Pick any of the font elements you want to change--another Fonts dialog will open showing all fonts present on your system. Select one and check box select the bold or the italic attribute if needed. Then OK to complete.

The font just picked will now show as a font selection for that element in addition to the default Liberation Serif. Repeat for other elements as needed.

Now proceed with creation of formulas.  And if pushing the resulting documents off your system, remember to insert the OLE formulas as copies to bring the fonts along with the formulas so they can be exported.

If that all works reasonably for you, please set this issue Resolved NotABug
Comment 4 Buovjaga 2014-11-16 13:07:34 UTC
Set to NEEDINFO because of comment 3.
Comment 5 Peter Schneider 2014-11-16 22:26:56 UTC
What you describe is a work around. The effect is still a bug, only the location for a fix changed.
So the font libre sans serif is broken.

Either that font has to be fixed in order to works for formulas
 or 
the default font in math has to be change to a font that actually works.
Comment 6 V Stuart Foote 2014-11-17 00:05:55 UTC
Created attachment 109570 [details]
same formula of OP with Liberation Serif -- noRepro
Comment 7 V Stuart Foote 2014-11-17 00:06:57 UTC
Created attachment 109571 [details]
Sample math document with formula

@Peter

Sorry, but I can not reproduce your exact issues of different sizing with Liberation Serif. Garamond Pro is just a more appealing example than Liberation Serif.

Is there any chance you have another source of Liberation fonts installed?

Please bring up the Format -> Fonts dialog and verify that Liberation Serif is set for Functions, Numbers and Text and that Variables are Liberation Serif, Italic.

Attached is a snip of the same formula, in Liberation Serif done on
Windows 7 sp1, 64-bit en-US with recent master
Version: 4.4.0.0.alpha2+
Build ID: 9229170920ab770624415c4330da57af5b1b5398
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-09_03:16:43

It renders the same and correctly with Liberation Serif on

Version: 4.3.4.1
Build ID: bc356b2f991740509f321d70e4512a6a54c5f243

Version: 4.4.0.0.alpha2
Build ID: 24f0a5815f581dd9a7f09d30213a379edee6e9ac

Stuart
Comment 8 Peter Schneider 2014-11-17 15:07:28 UTC
I'm a bit confused that you cannot reproduce the problem.
I have tried it on 5 different computers and all 5 behave as my screenshot shows.

If i open the document you posted i get exactly the same layouting error.

Which information do you need in order to reproduce?
Comment 9 Peter Schneider 2014-11-17 15:25:42 UTC
In order to test your theory that my fonts are broken, i did remove libre office completely, deleted all Librefonts and did a clean install with 4.3.4.1.

The described layout errors are still there.
Comment 10 V Stuart Foote 2014-11-17 16:16:33 UTC
@Peter,

Thank you for checking with the current 4.3.4.1 release build. 

Unfortunately, in addition to Windows 7 sp1, 64-bit en-US, I can not reproduce on Linux (32-bit, Fedora 20, LXDE, en-US) with a current 4.4.0alpha2+ master, or 4.2.6.3 build. Clips attached.

I suppose there could be a Language related mishandling of the fonts. What localization are you testing in? That looks to be Deutsch from your screen clip.

Stuart
Comment 11 V Stuart Foote 2014-11-17 16:17:51 UTC
Created attachment 109632 [details]
noRepro 4.2.6.3 on Linux (32-bit Fedora 20, LXDE en-US)
Comment 12 V Stuart Foote 2014-11-17 16:18:41 UTC
Created attachment 109633 [details]
noRepro 4.4.0alpha2+ on Linux (32-bit Fedora 20, LXDE en-US)
Comment 13 Peter Schneider 2014-11-18 05:46:36 UTC
LibreOffice Math
Version: 4.3.4.1
Build-ID: bc356b2f991740509f321d70e4512a6a54c5f243

German with German offline help package.
Comment 14 QA Administrators 2015-06-08 14:29:00 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!

This NEEDINFO Message was generated on: 2015-06-08

Warm Regards,
QA Team
Comment 15 Peter Schneider 2015-06-08 14:56:42 UTC
The Bug still persists and is 100% reproducable with a german libreoffice with windows.

I'm sorry that i cannot provide any other information than i have.

I tried it with 20 different computers (all german os german libreoffice os win7 and win8 win 8.1) and all show the behaviour shown in the screen shot.
Comment 16 Jochen 2015-06-08 18:36:29 UTC
I can reproduce (sizing with Liberation Serif)
LO 4.4.2
OS Windows 8.1
Comment 17 Arnaud LE CAM 2015-06-09 14:27:29 UTC
Created attachment 116421 [details]
no repro  5.0.0.0.beta1 Linux (64-bit Xubuntu  de-DE)

Version: 5.0.0.0.beta1
Build-ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Gebietsschema: de-DE (fr_FR.UTF-8)
Xubuntu 14.10
Linux 3.16.0-38

may it be a locales issue ?
Comment 18 Peter Schneider 2015-11-08 07:33:18 UTC
Fixed in 5.0.3.2
Comment 19 Buovjaga 2015-11-08 14:21:52 UTC
Thanks. Setting to WFM.