Bug 85901 - Hyperlink dialog has wrong size
Summary: Hyperlink dialog has wrong size
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha1
Hardware: Other All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, corruptProfile, regression
Depends on:
Blocks:
 
Reported: 2014-11-05 08:22 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-06-22 18:12 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
dialog before after after profile reset (75.11 KB, image/png)
2014-11-05 08:22 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-11-05 08:22:59 UTC
Created attachment 108935 [details]
dialog before after after profile reset

While running master, when i opened the hyperlink dialog, it was nearly the width of my screen. So then i reset my profile and open the dialog and its now scrunched.

Version: 4.4.0.0.alpha1+
Build ID: ad6d94009cf8ea526eb70bf1a07e5c6a21320f83
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-11-04_00:14:41
Comment 1 Buovjaga 2014-11-05 08:50:47 UTC
Confirmed, after resetting profile, the dialog shrunk in size. On Windows, it is practically ugly with the buttons so close.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: b7d8a58ff2698ffc6e22943f64aa97c5ea253bd9
TinderBox: Win-x86@42, Branch:master, Time: 2014-11-05_00:40:38
Comment 2 Andras Timar 2014-11-06 15:41:09 UTC
Probably caused by:
commit a51aa75d92eadaa613192a1773e0b78b0df74527
Author: Adolfo Jayme Barrientos <fitojb@ubuntu.com>
Date:   Sat Oct 18 08:25:16 2014 -0500

    fdo#78826 HIG: missing colons and capitalization in cui, filter
    
    * Fix capitalization
    * Standardize spacing
    * Standardize Help button’s position
Comment 3 Adolfo Jayme 2014-11-06 21:03:23 UTC
I doubt that that commit caused it. It only disabled manual resizing and moved the Help button. https://github.com/libreoffice/core/commit/a51aa75d92eadaa613192a1773e0b78b0df74527/cui/uiconfig/ui/hyperlinkdialog.ui

> So then i reset my profile and open the dialog and its now scrunched.

Why is that a bug? What am I missing?
Comment 4 Adolfo Jayme 2014-11-07 15:16:22 UTC
The “After” in your screenshot is the intended size.
Comment 5 Yousuf Philips (jay) (retired) 2014-11-08 00:30:01 UTC
After might be the correct size, but are users supposed to reset their profiles in order to not see this problem with the dialog, especially now that its not resizable.
Comment 6 Adolfo Jayme 2014-11-08 15:37:56 UTC
(In reply to Jay Philips from comment #5)
> After might be the correct size, but are users supposed to reset their
> profiles in order to not see this problem with the dialog, especially now
> that its not resizable.

If that’s a question, then yes. The QA team is always recommending people to reset their profiles. The only actual bug I see in this thread is that the dialog does not use its correct size when migrating a existing profile (i.e., the “Before” part of your screenshot).
But you’ve filed this bug saying that “the dialog has wrong size” and ”is scrunched”, and that corresponds to the “NOTABUG” status. ;)
Comment 7 Yousuf Philips (jay) (retired) 2014-11-08 20:03:32 UTC
(In reply to Adolfo Jayme from comment #6)
> The only actual bug I see in this thread is that the
> dialog does not use its correct size when migrating a existing profile
> (i.e., the “Before” part of your screenshot).

Yes that was the bug that i filed, the before part. I only showed the after part as i checked its state there as well.

> But you’ve filed this bug saying that “the dialog has wrong size” and ”is
> scrunched”, and that corresponds to the “NOTABUG” status. ;)

I filed "when i opened the hyperlink dialog, it was nearly the width of my screen" and "the dialog has wrong size" related to the huge size.
Comment 8 Cor Nouws 2015-03-12 21:45:15 UTC
IMO this is a duplicate of
 https://bugs.freedesktop.org/show_bug.cgi?id=83373
Comment 9 Stephan Bergmann 2015-03-13 08:02:04 UTC
(In reply to Adolfo Jayme from comment #6)
> (In reply to Jay Philips from comment #5)
> > After might be the correct size, but are users supposed to reset their
> > profiles in order to not see this problem with the dialog, especially now
> > that its not resizable.
> 
> If that’s a question, then yes. The QA team is always recommending people to
> reset their profiles.

This might be a misconception that needs clearing up:  While QA should ask people to temporarily move away existing user profiles in order to track down the cause of a misbehavior, users should never need to purge existing user profiles (modulo working around bugs).

> The only actual bug I see in this thread is that the
> dialog does not use its correct size when migrating a existing profile
> (i.e., the “Before” part of your screenshot).

But why classify this as NOTABUG then, given there is no way in LO to resize the dialog to a usable size?
Comment 10 Robinson Tryon (qubit) 2015-12-17 08:38:43 UTC
Migrating Whiteboard tags to Keywords: (bibisectRequest)
[NinjaEdit]
Comment 11 Yousuf Philips (jay) (retired) 2016-06-22 18:12:41 UTC
Same issue has happened again with the profile i've only used during 5.2's development and the hyperlink dialog has a minimum width of 1171px. Would be useful to track down what is causing this problem, so if anyone is interested in solving the issue, i'd be happy to provide my registrymodifications.xcu file.

Version: 5.2.0.0.beta1+
Build ID: 90e3e04841081b9c03ea54f1d5ca439a7a9ce1dd
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-2, Time: 2016-06-04_01:52:51
Locale: en-US (en_US.UTF-8)