Bug 85927 - bubble chart wizard is not working as expected
Summary: bubble chart wizard is not working as expected
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.7.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chart-Wizard
  Show dependency treegraph
 
Reported: 2014-11-05 18:24 UTC by Jan Wustrow
Modified: 2017-04-21 14:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
nearly perfect, but the ID in the diagram is not matching with the bubbles and topics (70.74 KB, image/png)
2014-11-05 18:24 UTC, Jan Wustrow
Details
wizard is ignoring the selected values (56.59 KB, image/png)
2014-11-05 18:28 UTC, Jan Wustrow
Details
bubble diagram test (28.30 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-02-04 10:40 UTC, Jan Wustrow
Details
Bubble chart example (16.15 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-02-08 00:26 UTC, Robinson Tryon (qubit)
Details
new version, with desired diagram state (31.86 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-02-09 10:41 UTC, Jan Wustrow
Details
screencast: bubble_test_screencast_20150210A.ogv (3.50 MB, video/ogg)
2015-02-10 09:21 UTC, Jan Wustrow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Wustrow 2014-11-05 18:24:33 UTC
Created attachment 108977 [details]
nearly perfect, but the ID in the diagram is not matching with the bubbles and topics

Hi,

first, it is hard to describe with the limitation to only one attachment.
If anybody really interested I can send all screenshots/screencasts.
I try it since days and the manual way cost me hours, because my data set is big.

---
I want to create a bubble diagram with the required minimum values
value name, bubble size, x-axis value, y-axis value

Optional field is ID to get a meaningful mark for the bubbles (color make no sense with docents of bubbles, because then you will have five different variations of every complementary color)

I found no way to create this result (attachment) via wizard.
Only the manual way is, more or less, working.

1st issue:
If I choose the data area in the second step of the wizard and I choose all data plus the topic then it will end in a mismatch.
The check marks regarding first column or row in the wizard menu has not the expected effect.
Every combination will not end in the attached result.

2nd issue:
As you can see, every Topic has an ID. But only the first ID will be shown with every bubble. This effect is also not working if I remove the ID set and try it only with the Topic column.

I found some minor issues but without screenshot or better a screencast it is hard to describe all.
But everyone who will try it can't finish without running in this mess to.

Btw, the same issues in MS-Office Excel or OpenOffice.
---

I'm willing to help and provide more details.

Thank you.


regards,

Jan
Comment 1 Jan Wustrow 2014-11-05 18:28:00 UTC
Created attachment 108980 [details]
wizard is ignoring the selected values
Comment 2 Robinson Tryon (qubit) 2015-02-03 18:31:12 UTC
Hi Jan,

Sounds like you've got multiple issues in this one report. Please make sure to file 1 bug per report.

Please attach an example file that reproduces the 1st problem here.

Status -> NEEDINFO

(After you provide the file, please change status back to UNCONFIRMED. Thanks!)
Comment 3 Jan Wustrow 2015-02-04 10:40:26 UTC
Created attachment 113116 [details]
bubble diagram test

This is an example file which shows the issue.
Comment 4 Jan Wustrow 2015-02-04 10:44:59 UTC
Hi Robinson,

example file is attached.
I can't really decide what of this issues is a bug (code) or misconfiguration or ... but all together is an incident of the bubble diagram function. :)

From my perspective there is no way to use the bubble function as designed.
But maybe I didn't understand how to use it correct.

Thx & regards,

Jan
Comment 5 Robinson Tryon (qubit) 2015-02-08 00:26:44 UTC
Created attachment 113217 [details]
Bubble chart example
Comment 6 Robinson Tryon (qubit) 2015-02-08 00:29:10 UTC
(In reply to Jan Wustrow from comment #4)
> I can't really decide what of this issues is a bug (code) or
> misconfiguration or ... but all together is an incident of the bubble
> diagram function. :)
> 
> From my perspective there is no way to use the bubble function as designed.
> But maybe I didn't understand how to use it correct.

Here's the documentation for the Bubble Chart:
https://help.libreoffice.org/Chart/Chart_Type_Bubble

I used that to create an example bubble chart (attachment 113217 [details]).

Is there something specific about the wizard that isn't working for you? Please provide a list of steps we can take to reproduce a specific problem. Right now, it's not clear to me what exactly is going wrong with the wizard.

Status -> NEEDINFO
Comment 7 Jan Wustrow 2015-02-09 10:40:45 UTC
Hi,

I attached a new calc file! This is showing the desired result.
bubble_test_20150209A.ods

It is not possible for me to get this result via wizard.
That means, without manual changes for every entry in the bubble diagram configuration.

The documentation (https://help.libreoffice.org/Chart/Chart_Type_Bubble)
sayed: "Two variables are used for the position on the X-axis and Y-axis, while the third variable is shown as the relative size of each bubble."

A) Does that mean that the order of the columns has to be "X,Y,SIZE" so that the wizard will work?
In the end I reordered the column and it doesn't work either.

B) It would be a loooooong text if I would describe all possible combination that I tried to bring the wizard to the desired result above.
I can create a screencast and provide the link for download here, should i?

C) Is there any step by step description that will show how it will works correctly?



best regards,

Jan



PS "Just for Info"

Imaginate you have dozens of entries.
The color will not longer help to identify the bubble.
To show the size of the bubble as "bubble description" is also not helpful and the name is mostly to long. Therefore I use the ID as identifier. But unfortunately this is also manual doing.
Comment 8 Jan Wustrow 2015-02-09 10:41:24 UTC
Created attachment 113250 [details]
new version, with desired diagram state
Comment 9 Robinson Tryon (qubit) 2015-02-09 14:15:33 UTC
(In reply to Jan Wustrow from comment #7)
> Hi,
> 
> I attached a new calc file! This is showing the desired result.
> bubble_test_20150209A.ods

Okay, I opened attachment 113250 [details], and the chart looks pretty reasonable. (Of course it's not immediately apparent how much work it took to get it into that state!)

> It is not possible for me to get this result via wizard.
> That means, without manual changes for every entry in the bubble diagram
> configuration.

Ideally, the wizard should be able to make that chart from that input.

> 
> The documentation (https://help.libreoffice.org/Chart/Chart_Type_Bubble)
> sayed: "Two variables are used for the position on the X-axis and Y-axis,
> while the third variable is shown as the relative size of each bubble."
> 
> A) Does that mean that the order of the columns has to be "X,Y,SIZE" so that
> the wizard will work?

That's the ordering I used in attachment 113217 [details], and the wizard worked immediately for me (without any special configuration).

> In the end I reordered the column and it doesn't work either.
> 

This sounds like it could be the start of some clear repro steps.

> B) It would be a loooooong text if I would describe all possible combination
> that I tried to bring the wizard to the desired result above.
> I can create a screencast and provide the link for download here, should i?

Sure. Short (< 10MB) WebM videos can just be attached to the bug report. Remember that our ideal goal is to identify just a single, specific defect or problem (e.g. documentation doesn't match code), so we can confirm it and then ship it off to the devs for fixing. We'd much rather have 5 very simple bugs than a single "the wizard fails" bug.

Status -> NEEDINFO

(Please change status back to UNCONFIRMED after you provide the screencast w/repro steps. Thanks!)

> 
> C) Is there any step by step description that will show how it will works
> correctly?

Not AFAIK, although you might get lucky if you search on Youtube?

> 
> PS "Just for Info"
> 
> Imaginate you have dozens of entries.
> The color will not longer help to identify the bubble.
> To show the size of the bubble as "bubble description" is also not helpful
> and the name is mostly to long. Therefore I use the ID as identifier. But
> unfortunately this is also manual doing.

This sounds like potentially another bug report, *possibly* an enhancement request re: large data sets...
Comment 10 Jan Wustrow 2015-02-10 09:20:11 UTC
Ok, I record my test runs and will attached it.
It is an ogv file, I hope it is working for you.

I did a combination of all possible settings in the wizard.
I know that the most of them can not work.
But as you see, no combination will deliver the result that I created manually.

The last setting in my screencast shows the possible correct combination.
From my point of view it is: "Data series in rows" and First column as label"
You will see that the values looks correct but the labels do not match and all values are connected to only one label.

I change my settings to "english (US)" for this test.

regards,

Jan
Comment 11 Jan Wustrow 2015-02-10 09:21:10 UTC
Created attachment 113282 [details]
screencast: bubble_test_screencast_20150210A.ogv
Comment 12 Robinson Tryon (qubit) 2015-02-12 23:18:00 UTC
(In reply to Jan Wustrow from comment #10)
> Ok, I record my test runs and will attached it.
> It is an ogv file, I hope it is working for you.

Hi Jan,
The OGV file looks great. It looks like there's no audio track, is that correct?

Thanks!
Comment 13 Jan Wustrow 2015-02-13 15:15:34 UTC
Hi Robinson,

yes, no audio track. I hope the pictures are distinct.
I would not discommode you with my voice. ;-) Maybe some music next time.

regards,

Jan
Comment 14 Jan Wustrow 2015-03-06 13:09:00 UTC
Hi all,

is there any additional information that I can deliver?
Could anybody reproduce the issue?

Thank you in advance.

regards,

Jan
Comment 15 Jan Wustrow 2015-05-20 10:19:07 UTC
Hi all,

I'm a little bit confused. I understand that this is not a commercial support but,
- did I not deliver any information that you need and has asked for?
- did I not cooperated in a proper way to support you?
- did I not react in proper time?
- did I not invest more time and effort that anybody else in the topic? 

Well, why is this topic completely ignored now?
From my point of view this whole bubble chart feature is broken because of blocking the simplest adjustments and the assistant is nearly useless.

Is this really so unimportant?
Would it not be better to remove this and any other not well working feature before people invest effort for nothing and finally are pissed of the product and change?

I do not blame the community nor the developer here.
But it would be nice to thing about the arguments and
maybe find a better way/strategy to create a proper product.
Comment 16 Buovjaga 2015-05-22 09:07:36 UTC
(In reply to Jan Wustrow from comment #11)
> Created attachment 113282 [details]
> screencast: bubble_test_screencast_20150210A.ogv

Reproduced with attachment 113116 [details] (not exact same data as in vid, but behavior matches).

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 83eb114394879cbfd073322a51c47d02553c1fcf
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-22_06:33:51
Locale: fi-FI (fi_FI)