Bug 86082 - Simple CALC file saved ODS will cause crash on load
Summary: Simple CALC file saved ODS will cause crash on load
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.6.3 release
Hardware: IA64 (Itanium) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-10 00:00 UTC by Ben
Modified: 2015-12-05 14:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
One cell text at A1 saved as ods causes crash on loading (11.23 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-11-10 00:00 UTC, Ben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben 2014-11-10 00:00:02 UTC
Created attachment 109179 [details]
One cell text at A1 saved as ods causes crash on loading

No files saved in ods work on load; they all cause Libreoffice to crash on unexpected error.  To better understand this, I created a simple spreadsheet, with the only thing in it at A1 being the word "Testing".  when I try to open it, Libreoffice crashes.

Interesting to note that Excel 2010 will open it after complaining a little bit, but it will open.  Also, I can open in Libreoffice ods files created in Excel 2010, just not anything created from Libreoffice.

I was experiencing this in latest version of Libreoffice, 4.3.3.5 (I think the last number was 5).  Thinking this might be the problem, I downloaded and installed version 4.2.6.3, but this is causing the same problem.

I have included the simple file I tested with.

Also note: if I go to 'properties' under file, it will also cause Libreoffice to crash!

Ben
Comment 1 Ben 2014-11-10 00:19:58 UTC
I must have missed it, but my computer is a HP Pavilion, 64 bit Windows Vista Home Premium.
Comment 2 m.a.riosv 2014-11-10 01:10:15 UTC
Hi @Ben, thanks for reporting.

I can't reproduce the issue.
Win7x64Ultimate
Version: 4.3.3.2
Build ID: 9bb7eadab57b6755b1265afa86e04bf45fbfc644

Please try resetting it, sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile
Comment 3 Ben 2014-11-10 20:59:45 UTC
I did perform the removal of the user profile as identified in the linked documentation.  Same results - Libreoffice crashes on trying to read a simple .ods file.

I then uninstalled the Libreoffice using the Windows software uninstall utility.  I also uninstalled Openoffice.  I deleted the AppData Libreoffice entries.  I rebooted the machine

I downloaded and installed the 4.3.3.2 version of Libreoffice.  I ran Libreoffice Calc, created a simple file with A1 having the word Testing in it, saved this as file.ods  I closed Libreoffice.  I reopened Libreoffice.  I tried to load the file just created ods file; Libreoffice crashed.  I went to the file and right clicked on it, selected 'open with' and specified Libreoffice.  Libreoffice crashed.

Nothing is working.  

When you said you couldn't replicate, were you testing on a Windows Vista Home Premium system?
Comment 4 m.a.riosv 2014-11-10 21:20:49 UTC
As you can see in my comment with Win7, I haven't a windows vista to verify with it.

Please try changing the options in Menu/Tools/Options/View - Graphics output.

In any case changed the status to unconfirmed, to make easy someone else try to verify the issue.
Comment 5 Julien Nabet 2014-11-11 10:43:26 UTC
- Is it a recent behaviour?
- do you have any accessibility tool enabled? (if yes, could you disable them for the test)

For the test, could you try raw method:
- uninstall any LO/Apache OOo/OpenOffice version
- remove any remnant directories in program files + LO profile
- clean your Windows registry with a free tool (eg: ccleaner)
- make sure you have a Java 32 bits (1.6 or 1.7) even if you use Windows 64 bits, since LO is only build in 32 bits for Windows
- install last stable LO version 4.3.3

Then, open Calc, just type "test" in a brand new file, save in ods, + reopen.

If it still crashes, it would be interesting to have a backtrace by following this link:
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_How_to_get_a_backtrace

Finally: do you have another Windows machine? (Itanium too?) If yes do you reproduce this too?
Comment 6 Ben 2014-11-15 19:25:23 UTC
Did all the things requested in Comment 5.  Still crashes.  Also tried new version 4.3.4 - same result.

It's interesting to note that Libreoffice will read the open doc format produced by Excel, but not that of it's own ods creation!

Thanks for your help, but I'm giving up and just going to use Excel from now on, as this is taking way too  much time and isn't getting anywhere. 

Thanks for your time in attempting to correct this.

Ben
Comment 7 Julien Nabet 2014-11-16 08:24:54 UTC
On pc Debian x86-64 with 4.3.3 LO Debian package,  I don't reproduce this.

Ben: ok you did all the things indicated in comment 5 and it didn't work but you didn't answer to questions (the 2 first lines and the last ones). Any chance you find some time to answer?

Michael: do you know someone who could test on Itanium hardware?
Comment 8 Ben 2014-11-16 11:53:12 UTC
OK, sorry for missing those.

Here's the first: - Is it a recent behaviour?

This is a laptop, and I had not used it in a while.  I've recently started using it again and updated the system software.  At some point recently I experienced this problem.  In the past I have been able to use this laptop with Libreoffice.  So yes, it is recently encountered, but after not being used for 6 months or longer.

- do you have any accessibility tool enabled? (if yes, could you disable them for the test).  

No, none that I'm aware of.

Thanks.
Comment 9 Julien Nabet 2014-11-17 20:47:06 UTC
Could you upgrade to 4.3.4?
Would it be possible you attach a backtrace? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_How_to_get_a_backtrace)
Comment 10 QA Administrators 2015-06-08 14:28:52 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!

This NEEDINFO Message was generated on: 2015-06-08

Warm Regards,
QA Team
Comment 11 Julien Nabet 2015-12-05 14:47:24 UTC
cleanup keywords + fix status.
If you still reproduce this with last stable LO version (5.0.3) + new LO profile, don't hesitate to reopen this tracker.