Bug 86204 - Starting angle for a pie chart does not match when .ods opened in Excel 2013
Summary: Starting angle for a pie chart does not match when .ods opened in Excel 2013
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Ľudovít Lučenič
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-12 14:42 UTC by Ľudovít Lučenič
Modified: 2014-12-01 23:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample .ods with graphs not aligned when opened in Excel 2013 (166.80 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-11-30 22:16 UTC, Ľudovít Lučenič
Details
XLSX version of ODS test file (20.12 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-12-01 22:08 UTC, Robinson Tryon (qubit)
Details
4.5 master vs Excel 2013 (204.65 KB, image/png)
2014-12-01 22:55 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ľudovít Lučenič 2014-11-12 14:42:31 UTC
I have created a pie chart, where the default value of starting angle equals 90 degrees. This setting causes the drawing in Calc starts at the top (or a most distant spot) either clockwise or counterclockwise based correctly on the other setting. When I open the file with this pie chart in Excel 2013, the drawing of it is offset by 90 degrees and starts from right (my graph has clockwise orientation). I assume the base position between Excel and Calc does not match.

Can this be solved, please, so that users with Excel do see the graph the same way I create them in Calc?

http://joxi.ru/Q2K07Dns4dQjAj
http://joxi.ru/VrwMlWoSOXQG2X

If anything is not clear from the Slovak language interface, just post me a message.
Thank you.
Comment 1 Robinson Tryon (qubit) 2014-11-13 01:28:40 UTC
(In reply to Ľudovít Lučenič from comment #0)
> I have created a pie chart, where the default value of starting angle equals
> 90 degrees. This setting causes the drawing in Calc starts at the top (or a
> most distant spot) either clockwise or counterclockwise based correctly on
> the other setting. When I open the file with this pie chart in Excel 2013,
> the drawing of it is offset by 90 degrees and starts from right (my graph
> has clockwise orientation). I assume the base position between Excel and
> Calc does not match.

Have you tried using an XLS or XLSX file?  (I'm curious if the behavior varies between XLS, XLSX, and ODS)

> Can this be solved, please, so that users with Excel do see the graph the
> same way I create them in Calc?

Possibly, although perhaps the base position (as you put it) is underspecified in the file format spec.

Please attach an example file to this bug report.  (when you've done that, please change the status back to 'UNCONFIRMED'. Thanks!)

Status -> NEEDINFO
Comment 2 Ľudovít Lučenič 2014-11-14 14:54:05 UTC
(In reply to Robinson Tryon (qubit) from comment #1)
> (In reply to Ľudovít Lučenič from comment #0)
> > I have created a pie chart, where the default value of starting angle equals
> > 90 degrees. This setting causes the drawing in Calc starts at the top (or a
> > most distant spot) either clockwise or counterclockwise based correctly on
> > the other setting. When I open the file with this pie chart in Excel 2013,
> > the drawing of it is offset by 90 degrees and starts from right (my graph
> > has clockwise orientation). I assume the base position between Excel and
> > Calc does not match.
> 
> Have you tried using an XLS or XLSX file?  (I'm curious if the behavior
> varies between XLS, XLSX, and ODS)
> 
Yes, it does. XLS is OK (i.e. same orientation as in Calc), XLSX reports some error while opening in Excel and ODS behaves as described.

> > Can this be solved, please, so that users with Excel do see the graph the
> > same way I create them in Calc?
> 
> Possibly, although perhaps the base position (as you put it) is
> underspecified in the file format spec.
> 
> Please attach an example file to this bug report.  (when you've done that,
> please change the status back to 'UNCONFIRMED'. Thanks!)
> 
> Status -> NEEDINFO
I will upload the files a bit later.
Comment 3 Ľudovít Lučenič 2014-11-30 22:16:21 UTC
Created attachment 110277 [details]
Sample .ods with graphs not aligned when opened in Excel 2013

I am providing the sample file. Let me know if any assistance is needed. Thank you.
Comment 4 Robinson Tryon (qubit) 2014-11-30 23:43:04 UTC
(In reply to Ľudovít Lučenič from comment #3)
> Created attachment 110277 [details]
> Sample .ods with graphs not aligned when opened in Excel 2013
> 
> I am providing the sample file. Let me know if any assistance is needed.
> Thank you.

Thanks for the sample file!

(In reply to Ľudovít Lučenič from comment #2)
> Yes, it does. XLS is OK (i.e. same orientation as in Calc), XLSX reports
> some error while opening in Excel 

Hmmm, that's no good. What's the error? (We might want to file a separate bug for that problem!)
Either way, it would be great if you could attach the sample XLSX to this bug.

Thanks!
Comment 5 Ľudovít Lučenič 2014-11-30 23:46:30 UTC
Hi Robinson,
save the sample .ods file in Calc as .xlsx and you should be able to reproduce the error when opening then in Excel. Let me know, if this works for you. Thank you.
Ludovit
Comment 6 Robinson Tryon (qubit) 2014-12-01 22:08:41 UTC
Created attachment 110324 [details]
XLSX version of ODS test file
Comment 7 Yousuf Philips (jay) (retired) 2014-12-01 22:55:43 UTC
Created attachment 110330 [details]
4.5 master vs Excel 2013

I can confirm that it is different in LibO compared to Excel 2013, but is this an Excel bug as its not interpreting ODF correctly or is this an LibO bug? I tried checking the file in Calligra Sheets and Gnumeric, but they didnt render the chart.

Version: 4.5.0.0.alpha0+
Build ID: 8bc56801af0540c0496c1f8ddd335578a8791017
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-11-28_23:01:06
Comment 8 Yousuf Philips (jay) (retired) 2014-12-01 22:58:14 UTC
Well i tested Excel 2010 and it rendered there correctly, so i'd say this was a MSO bug.
Comment 9 Robinson Tryon (qubit) 2014-12-01 23:02:47 UTC
(In reply to Jay Philips from comment #8)
> Well i tested Excel 2010 and it rendered there correctly, so i'd say this
> was a MSO bug.

Sounds like it's not our bug, but as there's no good way for us to poke the MS-Excel devs and ask them to take a look, I'll ask a Calc dev to verify.
Comment 10 Robinson Tryon (qubit) 2014-12-01 23:15:51 UTC
Chatted w/moggi. The disparity is possibly due to different interpretation of the spec (as I mentioned in comment 1), so marking RESOLVED NOTOURBUG.

Ludovit: If you're interested in pursuing this further, I suggest that you take a look at the ODF spec and see if you can identify if it specifies how these charts should be presented. If the position is underspecified, you can propose a change for the next version of ODF (v1.3). If the position is unambiguous, then we can determine whether LibreOffice or MSO (or both!) are incorrectly implementing ODF.