Bug 86339 - PRINT DIALOG: Window size changes when "details" are expanded/collapsed
Summary: PRINT DIALOG: Window size changes when "details" are expanded/collapsed
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-16 11:15 UTC by Olibuntu
Modified: 2014-11-17 13:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot (183.61 KB, image/png)
2014-11-16 11:26 UTC, Olibuntu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olibuntu 2014-11-16 11:15:12 UTC
In the print dialog, expanding or collapsing the "details" makes the window size change
Comment 1 Olibuntu 2014-11-16 11:26:05 UTC
Created attachment 109549 [details]
Screenshot
Comment 2 Olibuntu 2014-11-16 11:26:58 UTC
In the print dialog, expanding or collapsing the "details" makes the window size change.

This may be desired by the user or not, personally I would prefer my window at least not to become smaller than before.

However, if the window is in a maximized state, only a smaller portion of the window's interior is used afterwards (see screenshot), leaving its old contents in the remaining area, which is desturbing.  "De-maximizing" the window makes it look normal again, and one can maximize it afterwards.
Comment 3 Adolfo Jayme Barrientos 2014-11-16 14:14:24 UTC
I’ve disabled maximizing for that window in 4.4, so you shouldn’t run into that buggy situation with your window manager. It was a mistake to make those dialogs resizable in the first place.
Comment 4 Olibuntu 2014-11-16 18:02:43 UTC
(In reply to Adolfo Jayme from comment #3)

I would consider it only kind of a work-around to disable maximizing, not a fix.  Is the bug so hard to remove?

I very much appreciate the window being resizable!  In the original size of the window, the page preview is of comparably little use.  A large (or even maximized) window offers a really good impression of the whole page, which I don't want to miss.

So, can we reopen the bug?

From your comment I conclude that it may be an issue related to my window manager, which is Xfce shipped with Linux Mint 13.  So with other WMs the problem is absent?
Comment 5 Adolfo Jayme Barrientos 2014-11-17 09:42:30 UTC
(In reply to Olibuntu from comment #4)
> From your comment I conclude that it may be an issue related to my window
> manager, which is Xfce shipped with Linux Mint 13.  So with other WMs the
> problem is absent?

No, I’ve seen that situation in Compiz, for example, with Synaptic. It’s pretty common, but not LibreOffice’s fault.

Unfortunately you can’t disable maximizing without also disabling resizing under several Linux window managers.
Comment 6 Olibuntu 2014-11-17 13:04:41 UTC
When the dialog is resized, LO reacts correctly in resizing the page preview. So it seems that there is no principle problem with this task.

Couldn't the same function be called every time the "details" are collapsed or expanded?  So the window size would be retained and only the size of the page preview adjusted. Only if the window size was too small (which is not to be expected when the window is maximized) it would be enlarged.

Not knowing the code, I imagine this being a really simple solution, maybe only one function call is needed.