Bug Hunting Session
Bug 86391 - the math's elements panel is unusable [Hard to reproduce]
Summary: the math's elements panel is unusable [Hard to reproduce]
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-17 12:46 UTC by Anton
Modified: 2015-08-09 12:59 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
elements panel (7.52 KB, image/png)
2014-11-17 12:46 UTC, Anton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anton 2014-11-17 12:46:08 UTC
Created attachment 109617 [details]
elements panel

The math's elements panel is almost totally unusable. There are ugly unreadable icons. 

See screenshot.
Comment 1 Julien Nabet 2014-11-18 21:27:33 UTC
On pc Debian x86-64 with LO Debian package 4.3.3, I don't reproduce this.

On which Linux distrib are you?
Comment 2 Anton 2014-11-18 22:17:29 UTC
ubuntu trusty 14.4.1 x86-64
Comment 3 Julien Nabet 2014-11-19 06:42:18 UTC
Did you install 4.3.3.2 from LO ppa or from LO website?
If last one, perhaps you don't have a specific font.
Comment 4 Anton 2014-11-19 12:27:25 UTC
It was installed and updated from the ppa by system tools. 

Could you assist which font is to be installed?
Comment 5 Julien Nabet 2014-11-19 21:50:19 UTC
Instead of repeating a comment, I'll just quote it :-)
https://bugs.freedesktop.org/show_bug.cgi?id=83687#c3

Bjoern: thought you might be interested in this one since there might be a slight problem in Ubuntu package.
Comment 6 Anton 2014-11-21 08:21:38 UTC
I downloaded and installed a corresponding version of opens___.ttf as mentioned in https://bugs.freedesktop.org/show_bug.cgi?id=83687#c3

But no effect.
Comment 7 Julien Nabet 2014-11-21 08:52:41 UTC
Thank you for your feedback, I must recognize I'm stuck :-(
I put it back to UNCONFIRMED meanwhile since I don't have more questions.
Comment 8 Maxim Monastirsky 2014-11-21 10:19:19 UTC
Most likely a bug in the desktop theme or in the video driver (and related stuff). Try to switch to another desktop theme, or to turn off desktop effects. You could also try turn off hardware acceleration inside libreoffice (Tools->Options...->LibreOffice->View->Use hardware acceleration).
Comment 9 raal 2014-11-23 14:09:08 UTC
I can not confirm with version: 4.3.3.2 ID build: 430m0(Build:2), Ubuntu 14.10.
Comment 10 anthonyds12 2014-12-15 12:49:59 UTC
Also not reproducing on OS X 10.10.1 with LibreOffice 4.3.4.1
Comment 11 Robinson Tryon (qubit) 2015-01-17 10:07:07 UTC
(In reply to Maxim Monastirsky from comment #8)
> Most likely a bug in the desktop theme or in the video driver (and related
> stuff). Try to switch to another desktop theme, or to turn off desktop
> effects. You could also try turn off hardware acceleration inside
> libreoffice (Tools->Options...->LibreOffice->View->Use hardware
> acceleration).

Status -> NEEDINFO

Anton: Please try testing out maxim's suggestions above, and let us know how they work for you.

(After you test and reply, please change the status back to UNCONFIRMED. Thanks!)
Comment 12 Anton 2015-01-17 16:34:19 UTC
@Robinson Tryon 

No effect. 
I've already tried all possible: desktop theme, effects, fonts, hardware acceleration (I doubt it works at all)...

I have not recent ati radeon hd4570. 
And so I use default open driver and there are no any options to choose any other at all. 
Anyway thanks for your attention.
Comment 13 Julien Nabet 2015-01-17 17:59:05 UTC
Version must be the oldest one when one encounters the bug (see https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Version)
Comment 14 Robinson Tryon (qubit) 2015-01-17 20:11:44 UTC
(In reply to Anton from comment #2)
> ubuntu trusty 14.4.1 x86-64

Yep, NORPRO on Ubuntu 14.04.1 64bit
Testing with
LO 4.4.0.2 and
LO 4.5.0.0.alpha0+
  Build ID: 84c69550bcb8139669de9cf98b51c35f21fe853d
  TinderBox: Linux-rpm_deb-x86_64@46-TDF,
  Branch:master,
  Time: 2015-01-13_08:44:23
  Locale: en_US

Summary -> (hard to repro)
Comment 15 Adolfo Jayme 2015-08-09 12:59:51 UTC
This bug is obsolete, since we’ve removed that old Elements pane, which, by the way, used PNGs to render its icons (so it was never affected by missing fonts).