Bug Hunting Session
Bug 86407 - Chart crash with logarithmic axis when DS < 0
Summary: Chart crash with logarithmic axis when DS < 0
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-17 19:02 UTC by Domenico Somma
Modified: 2015-12-05 14:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
when the bars errors go under 0 in logarithmic chart it crashs (176.12 KB, image/jpeg)
2014-11-17 19:02 UTC, Domenico Somma
Details
when the bars errors go under 0 in logarithmic chart it crashs (211.58 KB, image/jpeg)
2014-11-17 19:19 UTC, Domenico Somma
Details
ods bug file (27.22 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-11-19 09:35 UTC, Domenico Somma
Details
gdbtrace (25.07 KB, text/plain)
2014-11-26 21:49 UTC, Domenico Somma
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Domenico Somma 2014-11-17 19:02:18 UTC
Created attachment 109637 [details]
when the bars errors go under 0 in logarithmic chart it crashs

Paste this values (for example) in Calc
x      	y	ds
0	100%	5%
90	10%	5%
and create a XY scatter plot. Change the y axis to logarithmic and insert the ds as Y error bars. 
The plot is correctly visualized. Now change the 10% (y value) to 1%. The plot crash. (See attachment)
This happens when the bars errors go under 0 in logarithmic chart.

In fact:
x	y	ds
0	100%	5%
90	5%	5%
work correctly 

x	y	ds
0	100%	5%
90	5%	5,1%
crash!

I tried on 3 different pc with Ubuntu and Arch, with libreoffice 4.2.7.2 and 4.3.3 (I'm not sure about this version)
Comment 1 Domenico Somma 2014-11-17 19:19:12 UTC
Created attachment 109639 [details]
when the bars errors go under 0 in logarithmic chart it crashs
Comment 2 Julien Nabet 2014-11-18 21:25:45 UTC
Could you attach the example file ? it will be quicker to test.
Comment 3 Domenico Somma 2014-11-19 09:35:45 UTC
Created attachment 109718 [details]
ods bug file
Comment 4 Julien Nabet 2014-11-19 21:45:16 UTC
Thank you for the attachment.
On pc Debian x86-64 with LO 4.3.3 Debian package, I don't reproduce the crash.

Would it be possible you attach a backtrace by following this link? https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
Comment 5 Domenico Somma 2014-11-26 21:49:14 UTC
Created attachment 110091 [details]
gdbtrace

Sorry for the delay. I've been busy.
I killed LO to obtain the gdb log.
it's good? Do you need anymore?
Comment 6 Julien Nabet 2014-11-26 22:07:11 UTC
Putting new since you've got a kindda of bt but I don't know how what to do with it since I don't see something to use.
Certainly other people may help but I can't here :-(
Comment 7 Caolán McNamara 2014-12-08 12:34:06 UTC
I load the document, over write cell J4 with 1, press enter, no crash in 4.2.7 for me or 4.3.5
Comment 8 Domenico Somma 2014-12-09 11:42:14 UTC
(In reply to Caolán McNamara from comment #7)
> I load the document, over write cell J4 with 1, press enter, no crash in
> 4.2.7 for me or 4.3.5

When you opened the file, do you see the chart on the right? Can you post a screenshot? Thanks...
Comment 9 Caolán McNamara 2015-02-05 11:30:51 UTC
my screenshot looks just like yours, a straight line.

To be certain we understand correctly, your application actually *crashes* when you enter 1 in there. Or is the bug that the chart collapses to a straight line, and there is no actual application crash ?
Comment 10 raal 2015-03-17 06:19:16 UTC
No crash with Version: 4.5.0.0.alpha0+
Build ID: 7f3628e54d4470cac6d51659d1b1bec5fb4f4e70
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-03-14_00:35:32

Please provide a clearer set of step-by-step instructions on how to reproduce the problem.
Comment 11 raal 2015-03-17 06:21:32 UTC
(In reply to Caolán McNamara from comment #9)
> my screenshot looks just like yours, a straight line.
> 
> To be certain we understand correctly, your application actually *crashes*
> when you enter 1 in there. Or is the bug that the chart collapses to a
> straight line, and there is no actual application crash ?

@Domenico,
what do you mean by "crash"?
Comment 12 Julien Nabet 2015-11-18 22:10:11 UTC
No feedback since more than 6 months, let's put this one to WFM.

Domenico: don't hesitate to reopen this tracker if you can still reproduce this with last stable LO version 5.0.3. In this case, please respond to comments 9, 10 and 11.
Comment 13 Julien Nabet 2015-12-05 14:49:00 UTC
cleanup keywords