Download it now!
Bug 86433 - Option to Automatically Create Versions of Documents
Summary: Option to Automatically Create Versions of Documents
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: File-Versioning
  Show dependency treegraph
 
Reported: 2014-11-18 12:48 UTC by paulo.f.rodriguez
Modified: 2017-04-18 16:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description paulo.f.rodriguez 2014-11-18 12:48:44 UTC
I would like to suggest the following enhancement:

Add the button save new version as a sub-option for save. Automatically the Libreoffice would create a git repo and register and would commit a new version in a transparent way to the user.

When openning it shoud have the option to visualize the most recent and the old versions.

(the other player in the mkt has this feature only if you use IE + sharepoint).
Comment 1 paulo.f.rodriguez 2014-11-18 15:01:58 UTC
sorry for the english mistakes, I wrote in a hurry.
Comment 2 Joel Madero 2014-11-20 15:51:57 UTC
Can you expand on this? So this is for development purposes....? I'm not sure I love the idea of potentially having thousands of branches on gerrit. Marking as NEEDINFO - please describe a bit more and then mark as UNCONFIRMED. Thanks
Comment 3 paulo.f.rodriguez 2014-11-20 16:03:53 UTC
Hello, Joel.
The idea is to have Libreoffice versioning the documents generated by itself. Example, I create a write doc, I save it normally. After sometime, I would like to edit it again to change some wording. Generaly, I have to copy the existing one and name it as 'v2' or 'v3'...or press  Save As after editing and save a new version. 

I would like to have libreoffice doing automaticaly, so I would press save version and the tool would save the previous and create the new one and control the versions by itself.

I use this on job with a 'paid tool you know the name' in association with a 'paid colaboration tool' and it goes versioning without my intervention including functionalities like checkin and checkout.

Let me know if I made it clearer.
Comment 4 Joel Madero 2014-11-20 16:06:48 UTC
Ah indeed that sounds more reasonable than I first thought :) 

Just a note, there is a "Save a copy" in the menus which is kind of similar...not really but a little bit.


So with this:

New
Enhancement


Just so you're aware, enhancements are largely done by volunteers, so a volunteer would have to come forward and be interested in implementing this. There is no guarantee that it will be implemented or, if it is, when that will be.


Thanks for the suggestion!
Comment 5 Jean-Baptiste Faure 2014-11-20 19:04:01 UTC
I fear it is a false good idea because if each save creates a new version, you will get many versions, and many users will not be happy with that. On the other hand these multiple versions will not be really manageable. Indeed the key function diff of Git or other version control systems can't be used to compare two binary files. Flat OpenDocument format (.fodt) has been created to workaround this issue.

That said, if I am not wrong, you have two ways to manage versions:
1/ use the menu File > Versions ...
2/ use CMIS protocol and your preferred CMS (Content Management System) to do the same thing as our competitor with IE and Sharepoint

Please, could you try and see if that match your need?

Best regards. JBF
Comment 6 Yousuf Philips (jay) (retired) 2017-04-18 16:28:05 UTC
As JBF mentioned, File > Versions provides the necessary automatic versioning functionality that is mentioned in this bug report.