Bug 86485 - FILEOPEN crashes whole LibreOffice when default namespace assigned assigned in [Content_Types].xml
Summary: FILEOPEN crashes whole LibreOffice when default namespace assigned assigned i...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: x86 (IA32) macOS (All)
: medium blocker
Assignee: Caolán McNamara
URL: https://bitbucket.org/openpyxl/openpy...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-20 08:53 UTC by Richard Kellner
Modified: 2014-11-20 09:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Error stack trace (67.97 KB, text/plain)
2014-11-20 08:53 UTC, Richard Kellner
Details
attaching it here locally as well (5.05 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-11-20 09:09 UTC, Caolán McNamara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Kellner 2014-11-20 08:53:45 UTC
Created attachment 109753 [details]
Error stack trace

xlsx file generated in python makes crash whole LibreOffice when opening the file.

Bug has been already reported in openpyxl library, but it seems that the problem is in LibreOffice its self.

For more details see: https://bitbucket.org/openpyxl/openpyxl/issue/384/libreoffice-on-mac-os-x-crash

Attached stack trace from LibreOffice crash on Mac OS X.
Comment 1 Caolán McNamara 2014-11-20 09:09:08 UTC
Created attachment 109754 [details]
attaching it here locally as well
Comment 2 Caolán McNamara 2014-11-20 09:11:41 UTC
unexpected exception in 4-3, ok in master, possibly one of the problems detected with coverity that just needs to be backported
Comment 3 Caolán McNamara 2014-11-20 09:16:19 UTC
Already fixed in master, backport proposed for 4-3 at https://gerrit.libreoffice.org/12981