Bug 86597 - Compile mysqlcppconn with mysql-connector-c++-1.1.4 and mariadb 10.0.11 fails
Summary: Compile mysqlcppconn with mysql-connector-c++-1.1.4 and mariadb 10.0.11 fails
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha2
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-23 01:30 UTC by rezso
Modified: 2014-12-16 15:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
compilefix (1.75 KB, text/plain)
2014-11-23 01:30 UTC, rezso
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rezso 2014-11-23 01:30:54 UTC
Created attachment 109879 [details]
compilefix

In mysql-connector-c++-1.1.4, the driver/nativeapi/libmysql_static_proxy.cpp contains an mysql_options4 call, which is undefined in mariadb < 10.0.14, so the build fails with undefined reference to `mysql_options4'.

Similar to this bug:
https://bugs.gentoo.org/520664?id=520664

The attached patch solves this error.
Comment 1 Buovjaga 2014-12-16 15:19:56 UTC
Please post patch to gerrit: https://wiki.documentfoundation.org/Development/gerrit/SubmitPatch
Thanks!