Bug 86715 - Format impossible to delete
Summary: Format impossible to delete
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-25 21:38 UTC by Dr. Matthias Weisser
Modified: 2014-11-26 09:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
testfile showing bold text not able to delete format (54.43 KB, application/vnd.oasis.opendocument.text)
2014-11-25 21:48 UTC, Dr. Matthias Weisser
Details
pdf file from odt showing the bold text problem (444.35 KB, application/octetstream)
2014-11-25 21:53 UTC, Dr. Matthias Weisser
Details
pdf file showing graphic problem in comparison (249.49 KB, application/octetstream)
2014-11-25 22:07 UTC, Dr. Matthias Weisser
Details
pdf file showing graphic problem in comparison (149.03 KB, application/octetstream)
2014-11-25 22:08 UTC, Dr. Matthias Weisser
Details
pdf showing table of content problem (61.80 KB, application/octetstream)
2014-11-25 22:22 UTC, Dr. Matthias Weisser
Details
pdf showing table of content problem in comparison (65.88 KB, application/octetstream)
2014-11-25 22:24 UTC, Dr. Matthias Weisser
Details
pdf showing part which I added before problem occurred (337.17 KB, application/octetstream)
2014-11-26 06:12 UTC, Dr. Matthias Weisser
Details
pdf showing the corrupted table of contents (105.39 KB, application/octetstream)
2014-11-26 06:15 UTC, Dr. Matthias Weisser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dr. Matthias Weisser 2014-11-25 21:38:53 UTC
I am writing books. Doing this I added some text and got problems with the table of contents. Instead of only giving the title line in the table of contents the whole text appeared. 

To fix this I tried to reset all format. This fixed the problem with the table of contents but unfortunately now some text is shown fat. Its not possible getting rid of this using "format" "direkte formatierung loeschen". 

Because the text is a real book I am not willing to give this here for free to the whole world. Per personal email its possible of course. 

To show the problem I made some files odt and pdf.
Comment 1 Dr. Matthias Weisser 2014-11-25 21:48:17 UTC
Created attachment 110014 [details]
testfile showing bold text not able to delete format

see text on page 13. In the middle when "An Fette.." appears the text is shown bold. Its not intended there. It should be normal. Its not possible deleting this format using "format" "direkte formatierung loeschen". It just stays as it is. 

Seems to be there is something hidden in the code. But unfortunately there is no toos there to see this. Therefore not so easy to get rid of it.
Comment 2 Dr. Matthias Weisser 2014-11-25 21:53:17 UTC
Created attachment 110015 [details]
pdf file from odt showing the bold text problem

on page 13 the text changes to bold. Its so on page 14 and partially on page 15 and 16. No chance getting rid of this format using the format delete from the format top menu.
Comment 3 Dr. Matthias Weisser 2014-11-25 22:07:00 UTC
Created attachment 110016 [details]
pdf file showing graphic problem in comparison

the files 14_krebs_zeta_old115_ausschnitt.pdf and 14_krebs_zeta_old116_ausschnitt.pdf should be quite identical because the source file has been the same. 116 is the follower of 115. 115 was saved from 114 and 116 was saved from 115. Unfortunately the pages are differing in numbering. And more important 116 is damaged on page no. 40 (see the missing picture). Why is this happening?
Comment 4 Dr. Matthias Weisser 2014-11-25 22:08:32 UTC
Created attachment 110017 [details]
pdf file showing graphic problem in comparison

the file to compare with 115 showing the graphic problem on page no. 40.
Comment 5 Dr. Matthias Weisser 2014-11-25 22:22:45 UTC
Created attachment 110018 [details]
pdf showing table of content problem

this file shows that the table of content got mixed up with text somehow. This was not intended !
 
To get rid of this I deleted format using "format" "direkte formatierung loeschen". This worked for correcting the table of contents. But unfortunately the file got corrupt somehow on page 40. See the other pdf. 

Also unfortunately the text went bold and being now bold cannot be made normal using "format" "direkte formatierung loeschen". This is not what I feel should happen when using this command. Format should vanish - not sustain. 

There is no feedback from the code ! So I cannot see whats going wrong and correct manually ! Thats really a pity. In html I am using dreamweaver and can have a look at layout and code at the same time. Therefore its easy correcting such problems. There is no similar feature there in LO. 

Delete format does not work as intended.
Comment 6 Dr. Matthias Weisser 2014-11-25 22:24:32 UTC
Created attachment 110019 [details]
pdf showing table of content problem in comparison

file to show problem in comparison. Here probkem is fixed by removing format.
Comment 7 Dr. Matthias Weisser 2014-11-25 22:44:42 UTC
Operating system is WinXP.
Comment 8 m.a.riosv 2014-11-25 22:54:58 UTC
Hi Matthias, thanks for reporting.

As I see the "An Fette.." has a *character style* applied "Strong Emphasis" so you can't delete it with Ctrl+M (Clearing direct formatting), you need to restore their style to "Default Style" for character, which can be found with [F11] in the second icon.

Works for me with 4.2.7

Closed as not a bug, please if you are not agree reopen it.
Comment 9 Dr. Matthias Weisser 2014-11-26 05:31:02 UTC
thank you very much for this hint. My intention for opening this still is that this was happened here was a very frustrating work experience for me.

It did not happen the first time. I was not able fixing this alone. 

I need to get help from the experts here solving this.

The other problem that came up was the problem with the table of contents and the crushed picture on page 40. 

So this should not be closed now so fast. Better to have a look at what happened and how to get rid of such problems in future.

This is my opinion. Surely there are others.
Comment 10 Dr. Matthias Weisser 2014-11-26 06:12:38 UTC
Created attachment 110030 [details]
pdf showing part which I added before problem occurred

the text should look like this. Here is no problem to see. "An Fette.." is not bold. The problem is to see in the table of contents. Why was I running into this trouble? What can I do solving this without corrupting the document which happened to 116?

Another problem is that the pdf export from page 57 to 60 did not start from page 57 but from 58 instead. Therefore I had to start the export from 56 to also get 57. Is this intended? Was frustrating for me. May be the same for others.
Comment 11 Dr. Matthias Weisser 2014-11-26 06:15:35 UTC
Created attachment 110031 [details]
pdf showing the corrupted table of contents

this behavior happened after adding those 3 pages to this document. Why is this so? How to fix it correctly without corrupting the other text as happened in 116.
Comment 12 m.a.riosv 2014-11-26 09:08:29 UTC
Hi Matthias, forgive, this is a system to report bugs not to ask for help.

Please, ask for help in:
http://ask.libreoffice.org/en/questions/ in English, or  http://ask.libreoffice.org/de/questions/ in Germany,
afterwards if really seems a bug, please report here, but please if possible only one bug at once.