Bug Hunting Session
Bug 86717 - LibreOffice freezes (not responding) for a long time of associated printer is not responding
Summary: LibreOffice freezes (not responding) for a long time of associated printer is...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-25 23:21 UTC by Daniel Dickinson
Modified: 2016-05-02 12:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Dickinson 2014-11-25 23:21:26 UTC
Under Windows 8.1, if the printer associated with (at least) a Calc document is in a state where it is not responding then attempting to open that spreadsheet will result in LibreOffice freezing (Windows reports 'Not Responding' and no input/actions possible) for a very long time.

It seems that LibreOffice requires a response from the printer, (or timeout) before an open operation (at least) can be completed sufficiently for access to the UI, or even showing anything other than a grey window.

This occurs, for instance, for an IPP network printer that is currently offline.
Comment 1 raal 2016-05-02 10:07:23 UTC
I can not confirm with Version: 5.2.0.0.alpha0+; win7

steps
File – printer settings
select network printer
close file

detach network cable
open file
No freeze

PLease retest with actual version of LO. Thank you.
Comment 2 Daniel Dickinson 2016-05-02 12:00:55 UTC
This bug is so ancient that it's irrelevant and I only use LibreOffice on Linux now - on Windows I use MS Office because the only time I use Windows is when I have to be compatible with Windows folks.
Comment 3 raal 2016-05-02 12:20:17 UTC
And do you observe this bug on Linux?
Comment 4 Daniel Dickinson 2016-05-02 12:23:26 UTC
No, it was only an issue on Windows in 2014 (note the date of original report), so probably it's not even an issue on Windows now.
Comment 5 raal 2016-05-02 12:34:35 UTC
Thank for info, closing for now. If bug occurs again, set to unconfirmed. Thanks.