Download it now!
Bug 86719 - (Base Database) always tries to connect ODBC using iODBC, not unixODBC on Mac OSX 10.10
Summary: (Base Database) always tries to connect ODBC using iODBC, not unixODBC on Mac...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: All Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-26 01:20 UTC by June
Modified: 2015-03-06 21:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description June 2014-11-26 01:20:52 UTC
Problem description: 

I am using Libre Office Version: 4.3.4.1 on my Mac OSX 10.10 Yosemite.

In Base Database, I would like to connect MS-SQL server using unixODBC DSN.

But it seems the Libre Office tries to connect via iODBC, not unixODBC. (I never installed iODBC on my Mac.)



Steps to reproduce:
1. Following the below link, I already setup unixODBC, FreeTDS using Homebrew and all the tsql/isql connection tests were fine.
http://www.joecjr.com/2014/07/27/install-and-use-freetds-unixodbc-and-rodbc-or-pyodbc/

2. After installing, I launched "Database Wizard" from Base database. And choose 'ODBC' from "Connect to an existing database", I entered s01, my unixODBC DSN name, to "Name of the ODBC data source on your system" field. (When I clicked 'Browse' no registered data source were shown.) And I typed my unixODBC username and checked Password required.

3. When I clicked 'Test Connection' button and input the password, an error occurred as below.

[iODBC][Driver Manager]Data source name not found and no default driver specified. Driver could not be loaded.


Current behavior:
SQL Status: IM002

[iODBC][Driver Manager]Data source name not found and no default driver specified. Driver could not be loaded


Expected behavior:
Establishing an ODBC connection using unixODBC.
Comment 1 Alex Thurgood 2014-11-26 10:43:04 UTC
The ODBCAdmin tool and corresponding iodbc libraries are no longer present by default, but can still be installed, either from Apple, or now, a more recent app bundle called ODBC_Manager, have you tried that instead of unixODBC ? It could well be that the LO production build is made with the libraries from the ODBCAdmin tool (system dev libs) and therefore not unixODBC dev libs
Comment 2 Alex Thurgood 2014-11-26 16:23:55 UTC
As a cvomparison, I use ODBC Manager, MySQL odbc driver 5.3 and LO 4332 on OSX 10.10 and it works.
Comment 3 Alex Thurgood 2014-11-30 11:59:27 UTC
Setting to needinfo as unixodbc is not required for odbc access, when OS-native solution exists.
Please test with "ODBC Manager.app" and report back
Comment 4 Alex Thurgood 2015-01-03 17:38:57 UTC
Adding self to CC if not already on
Comment 5 Julien Nabet 2015-03-06 21:12:04 UTC
No feedback since more 3 months + Alex's test is ok => let's put this one to WFM.

June: don't hesitate to reopen this tracker if you can still reproduce even after having followed Alex's advice +, if needed, having upgraded to last stable LO version (4.3.6 or brand new 4.4.1)