Bug 86749 - Line Spacing wrong with MetaNormal font
Summary: Line Spacing wrong with MetaNormal font
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-26 18:46 UTC by Muppel
Modified: 2016-05-09 20:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
PDF exported from ODT on Windows (11.11 KB, image/png)
2014-11-26 18:46 UTC, Muppel
Details
PDF exported from ODT on Windows (11.11 KB, image/png)
2014-11-26 18:48 UTC, Muppel
Details
PDF exported from ODT on Ubuntu (10.73 KB, image/png)
2014-11-26 18:49 UTC, Muppel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Muppel 2014-11-26 18:46:43 UTC
Created attachment 110081 [details]
PDF exported from ODT on Windows

When exporting an ODT file to PDF using headless mode on Ubuntu 14.04.1 LTS and LO 4.2.7.2 or 4.3.4.1, there is a sginificant discrepancy in line spacing to the original layout if the MetaNormal font is used.
The same font with bold weight renders as expected.

Exporting the same ODT file via Export dialogue on Windows generates a PDF that looks identical to the original document.

The TTF is installed in a subdirectory of /usr/share/fonts/truetype/.
Comment 1 Muppel 2014-11-26 18:48:35 UTC
Created attachment 110082 [details]
PDF exported from ODT on Windows
Comment 2 Muppel 2014-11-26 18:49:15 UTC
Created attachment 110083 [details]
PDF exported from ODT on Ubuntu
Comment 3 Robinson Tryon (qubit) 2015-01-03 20:14:13 UTC
(In reply to Muppel from comment #0)
> When exporting an ODT file to PDF using headless mode on Ubuntu 14.04.1 LTS
> and LO 4.2.7.2 or 4.3.4.1, there is a sginificant discrepancy in line
> spacing to the original layout if the MetaNormal font is used.
> The same font with bold weight renders as expected.

We don't ship the MetaNormal font. Where can one find it?

> Exporting the same ODT file via Export dialogue on Windows generates a PDF
> that looks identical to the original document.
> 
> The TTF is installed in a subdirectory of /usr/share/fonts/truetype/.

Please upload a test ODT (that will reduce the variables when trying to reproduce the problem).

Status -> NEEDINFO

(please change status back to UNCONFIRMED after you attach the ODT)
Comment 4 QA Administrators 2015-12-27 20:31:56 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 5 QA Administrators 2016-05-09 20:08:51 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

This INVALID Message was generated on: 2016-05-09