Bug 86900 - Libre Office crashes on startup under OSX (10.9.5)
Summary: Libre Office crashes on startup under OSX (10.9.5)
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: x86-64 (AMD64) macOS (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-01 11:13 UTC by jonaslaugs
Modified: 2015-07-18 17:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
OSX Crash Details (51.07 KB, text/plain)
2014-12-01 11:13 UTC, jonaslaugs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jonaslaugs 2014-12-01 11:13:46 UTC
Created attachment 110292 [details]
OSX Crash Details

I'm running LO 3.4.3 at the moment and 4.3.4 and 4.2.7 both crash at startup. Deleting the Libre Office folder in library for a fresh start doesn't help. Didn't find any .plists. I'll attach the OSX error thingeby.

Pretty annyong, but 3.4.3 works fine so …
Comment 1 Alex Thurgood 2014-12-01 14:06:47 UTC
Can not reproduce with LO 4341 on OSX 10.10.1
Comment 2 Alex Thurgood 2014-12-01 14:09:16 UTC
Are you running :

- 3rd party window tiling software ?
- assistive technology software or devices that use this API ?

Do you have Java 6 from Apple installed ?

setting to needinfo
Comment 3 jonaslaugs 2014-12-01 14:22:36 UTC
> - 3rd party window tiling software ?
> - assistive technology software or devices that use this API ?

Not that I know of. I do have BetterTouchTool but I don't use  it (no autostart) and it doesn't seem to work anymore, needs update, yaddayadda) How can I check that? I didn't find anything in Sysprefs > Assistant Technology (I'm on a German Mac, so I'm not sure of the Englisch wordings). Alfred? XtraFinder?


> Do you have Java 6 from Apple installed ?

I seem to have Java 7(?).
Comment 4 Alex Thurgood 2014-12-01 20:43:51 UTC
You need Apple Java 6 for OSX too, please see bug 74877
Comment 5 Alex Thurgood 2014-12-01 20:47:51 UTC
The BetterTouchTool is/was also believed to cause problems in the past on OSX with previous versions of LO
Comment 6 Alex Thurgood 2014-12-01 20:49:21 UTC
Also try removing/renaming your LO user profile folder in Library Support and restarting LO after installing Java 6
Comment 7 jonaslaugs 2014-12-02 15:43:52 UTC
Do I need to uninstall Java 7 to get Java 6? I tried this* and it installed without problems but Java SysPrefs still say 1.7 and LO is still crashing (I deleted the LO office in Library after installing Java 6).

* https://support.apple.com/kb/dl1572
Comment 8 QA Administrators 2015-06-08 14:28:30 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!

This NEEDINFO Message was generated on: 2015-06-08

Warm Regards,
QA Team
Comment 9 QA Administrators 2015-07-18 17:27:10 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO

Message generated on: 2015-07-18