Bug 86915 - [XLSX] Function SUMIFS isn't correctly imported
Summary: [XLSX] Function SUMIFS isn't correctly imported
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-01 20:54 UTC by Teo91
Modified: 2016-07-14 14:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
XLSX with SUMIFS function not imported (cell C10) (6.51 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-12-01 20:54 UTC, Teo91
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Teo91 2014-12-01 20:54:17 UTC
Created attachment 110321 [details]
XLSX with SUMIFS function not imported (cell C10)

Problem description:

Function SUMIFS in the attached .xlsx is imported as "_xlfn.sumifs"
 
Steps to reproduce:
1. open the .xlsx attached
2. go to cell C10
3. function name is =_xlfn.sumifs(C2:C7;A2:A7;A10;B2:B7;B10)

Current behavior:

SUMIFS function from Excel spreadsheet is imported as "_xlfn.sumifs"

Expected behavior:

SUMIFS function should be imported correctly as SUMIFS.
Comment 1 m.a.riosv 2014-12-01 23:55:36 UTC
Hi @Teo91, thanks for reporting.

Seems the issue is already in the file.

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<worksheet xmlns:r="http://schemas.openxmlformats.org/officeDocument/2006/relationships" xmlns="http://schemas.openxmlformats.org/spreadsheetml/2006/main"><dimension ref="A1:D10"/><sheetViews><sheetView tabSelected="1" workbookViewId="0"><selection activeCell="B11" sqref="B11"/></sheetView></sheetViews><sheetFormatPr defaultRowHeight="14.25"/><cols><col min="1" max="1" customWidth="1" width="14.746094" style="1"/><col min="2" max="2" customWidth="1" width="14.996094" style="2"/><col min="3" max="3" customWidth="1" width="8.886719" style="3"/><col min="257" max="16384" width="9" style="0" hidden="0"/></cols><sheetData><row r="1" spans="8:8" ht="15.0"><c r="A1" s="1" t="s"><v>0</v></c><c r="B1" s="2" t="s"><v>1</v></c><c r="C1" s="3" t="s"><v>2</v></c></row><row r="2" spans="8:8" ht="15.0"><c r="A2" s="1"><v>41974.0</v></c><c r="B2" s="2" t="s"><v>3</v></c><c r="C2" s="3"><v>10.0</v></c></row><row r="3" spans="8:8" ht="15.0"><c r="A3" s="1"><v>41944.0</v></c><c r="B3" s="2" t="s"><v>4</v></c><c r="C3" s="3"><v>12.0</v></c></row><row r="4" spans="8:8" ht="15.0"><c r="A4" s="1"><v>41609.0</v></c><c r="B4" s="2" t="s"><v>5</v></c><c r="C4" s="3"><v>20.0</v></c></row><row r="5" spans="8:8" ht="15.0"><c r="A5" s="1"><v>41579.0</v></c><c r="B5" s="2" t="s"><v>6</v></c><c r="C5" s="3"><v>22.0</v></c></row><row r="6" spans="8:8" ht="15.0"><c r="A6" s="1"><v>41944.0</v></c><c r="B6" s="2" t="s"><v>7</v></c><c r="C6" s="3"><v>21.0</v></c></row><row r="7" spans="8:8" ht="15.0"><c r="A7" s="1"><v>41609.0</v></c><c r="B7" s="2" t="s"><v>8</v></c><c r="C7" s="3"><v>20.0</v></c></row><row r="10" spans="8:8" ht="15.0"><c r="A10" s="1">

<v>41974.0</v></c><c r="B10" s="2" t="s"><v>10</v></c><c r="C10" s="3"><f>_xlfn.SUMIFS(C2:C7,A2:A7,A10,B2:B7,B10)

</f><v>10.0</v></c></row></sheetData><pageMargins left="0.7" right="0.7" top="0.75" bottom="0.75" header="0.3" footer="0.3"/><pageSetup paperSize="0" scale="285" orientation="landscape" copies="116"/></worksheet>

Modifying the cell, saving and reopening works fine for me with 4.3.4.1 and 4.3.5.1
Comment 2 raal 2014-12-02 08:01:37 UTC
I can open with excel 2010 without problem. When I resave file in excel 2010 I can see correct formula SUMIFS in LO 4.3.4

How the file is created? I see <Application>WPS Office</Application> in xlxs file.
Comment 3 Teo91 2014-12-02 17:48:36 UTC
Thanks anyone for the help!

The .xlsx file was created using WPS Kingsoft Office mobile app.
The bug is clearly on their side, so I'll close this report as RESOLVED NOTOURBUG.