Bug Hunting Session
Bug 86977 - Wrong character set after pasting plain text
Summary: Wrong character set after pasting plain text
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha2
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-03 17:06 UTC by Urmas
Modified: 2017-03-28 08:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2014-12-03 17:06:50 UTC
When pasting text coming from non-Unicode applications, it is pasted in the encoding corresponding to the user locale setting.
The Unicode text should be used instead, as the user can control its encoding via keyboard layout.
Comment 1 Michael 2015-05-23 14:26:49 UTC
Can you give us a sample text from a non-unicode application so we can reproduce this?
Comment 2 Urmas 2015-05-23 17:37:33 UTC
You need an application, not a text. Any non-ASCII characters will do.
Comment 3 Buovjaga 2015-06-08 10:08:34 UTC
Can you give some example applications for Windows? I tried searching for the information on the web, but was unable to find a specific example.
Comment 4 Robinson Tryon (qubit) 2016-08-04 23:33:47 UTC
(In reply to Buovjaga from comment #3)
> Can you give some example applications for Windows? I tried searching for
> the information on the web, but was unable to find a specific example.

Looks like we're still trying to find an appropriate application on Windows? Assuming this bug still exists, let's try to find an appropriate app and a quick set of repro steps (with Expected vs. Actual pasted text) so we can verify the bug and devs can then fix it.

Status -> NEEDINFO
Comment 5 QA Administrators 2017-03-01 10:41:17 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2017-03-28 08:13:15 UTC Comment hidden (obsolete)