Bug 87022 - Extensive Memory Use, Sluggish Behaviour after selecting the entire sheet contents
Summary: Extensive Memory Use, Sluggish Behaviour after selecting the entire sheet con...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: x86-64 (AMD64) Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-12-05 07:10 UTC by thangalin
Modified: 2016-09-28 18:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example spreadsheet to demonstrate the sluggish behaviour (52.67 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-12-07 22:49 UTC, thangalin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thangalin 2014-12-05 07:10:06 UTC
LibreOffice slows to a crawl after selecting the entire sheet contents.

Replicate

1. Create a new spreadsheet in LibreOffice
2. Add ~20 rows and ~10 columns of data
3. Highlight (select) the first row by clicking the "1" on row 1
4. Press CTRL+B to bold the first row
5. Press CTRL+E to center the first row
6. Type CTRL+A to select the entire spreadsheet
7. Type CTRL+M to normalize the text

Expected Results

Using the arrow keys should continue to navigate the cells quite quickly.

Actual Results

There is a noticeable lag when using keyboard navigation.

Work Around

Save the spreadsheet, restart LibreOffice.
Comment 1 tommy27 2014-12-06 15:38:25 UTC
please upload a test file where you exactly reproduce the issue.
providing a test case will speed up QA job. thanks for your understanding.

is the issue you report something limited to the 4.3.4.1 version you are using or did you already noticed it on earlier version?

which is your exact Linux distro?
Comment 2 thangalin 2014-12-07 22:49:58 UTC
Created attachment 110548 [details]
Example spreadsheet to demonstrate the sluggish behaviour

Load the attached file into LibreOffice, then:

1. Type CTRL+A to select the entire spreadsheet
2. Type CTRL+M to normalize the text
3. Immediately start using the arrow keys to navigate the cells
Comment 3 thangalin 2014-12-07 22:50:54 UTC
$ soffice --version
LibreOffice 4.3.4.1 bc356b2f991740509f321d70e4512a6a54c5f243

$ uname -a
Linux 3.13.0-40-generic #69-Ubuntu SMP Thu Nov 13 17:53:56 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

$ cat /etc/issue
Ubuntu 14.04.1 LTS \n \l
Comment 4 thangalin 2014-12-07 22:51:58 UTC
I noticed the behaviour in a previous version and subsequently upgraded to 4.3.4.1 to see if the issue had been resolved already.
Comment 5 tommy27 2014-12-08 08:16:17 UTC
I don't reproduce this bug under Win8.1x64 using LO 4.3.4.1
maybe a Linux specific issue. needs another Linux tester
Comment 6 Buovjaga 2014-12-16 13:27:44 UTC
Reproduced lag -> NEW.

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: f92183833fa569006602ac7e93c906d2094e0d4d
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-12-14_00:21:45
Comment 7 Buovjaga 2015-01-12 15:46:12 UTC
3.5 doesn't seem to have any lag after the ctrl-a ctrl-m.

Ubuntu 14.10 64-bit
LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 8 Michael Weghorn 2015-02-06 23:35:15 UTC
I bibisected this. Unfortunately, many commits failed to start with "ERROR 4 forking process". Therefore I had to "git bisect skip" them.


bibisect result:

There are only 'skip'ped commits left to test.
The first bad commit could be any of:
a043626b542eb8314218d7439534dce2fc325304
79ff8e93eb0ddcebca4f814fc6883da8e1485c9f
ae627c725e93b01ef68cf242574f40eb9885e3c9
91460ba3ce3a0efa5693f098c1072b058903a31c
We cannot bisect more!


$ git bisect log
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect bad 4850941efe43ae800be5c76e1102ab80ac2c085d
# skip: [a043626b542eb8314218d7439534dce2fc325304] source-hash-9379a922c07df3cdb7d567cc88dfaaa39ead3681
git bisect skip a043626b542eb8314218d7439534dce2fc325304
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# good: [1d4980621741d3050a5fe61b247c157d769988f2] source-hash-89d01a7d8028ddb765e02c116d202a2435894217
git bisect good 1d4980621741d3050a5fe61b247c157d769988f2
# skip: [89110ca258fa7a15dfc546acfb39e76fc3eb2a44] source-hash-e450a2c506ac7cd4433b0f93fc750a89919bc03c
git bisect skip 89110ca258fa7a15dfc546acfb39e76fc3eb2a44
# good: [1cca92a409385d9288c28a54d5e3008e56728bc0] source-hash-7be7824bbbdeee6fa998b950e6046ab37fe690cb
git bisect good 1cca92a409385d9288c28a54d5e3008e56728bc0
# skip: [5fa28ce2931a35ae64ae08d3904cfb76d24459d8] source-hash-2304beaca33c63b94df99cb827716f00ce259f9a
git bisect skip 5fa28ce2931a35ae64ae08d3904cfb76d24459d8
# bad: [2a9ff869c5638dc5c3aa387d0fe55c3291c86288] source-hash-01b7e04172889cbc9e4ac404b105e18ddc062d6f
git bisect bad 2a9ff869c5638dc5c3aa387d0fe55c3291c86288
# good: [9771d0c212cfa71b07742ff3dc5c05df22d600eb] source-hash-a9a0933ec67eab0ec31c8fadb60fb8e8e3e90485
git bisect good 9771d0c212cfa71b07742ff3dc5c05df22d600eb
# skip: [edd0c98bc8eba396299d252906dea0898436e42a] source-hash-6489f97fc428446c53c17f885963776cdcc21490
git bisect skip edd0c98bc8eba396299d252906dea0898436e42a
# skip: [9fc19519e5bc25b68aff579d6f6dd57553e21cb4] source-hash-d63a69a087c9c7641e28e2002d7ad56076d08ca1
git bisect skip 9fc19519e5bc25b68aff579d6f6dd57553e21cb4
# skip: [8cb23b3181bfae3988e27d5621476e8fc74ab823] source-hash-132731f0704b5a9e996cb0d413c8e369efe8875f
git bisect skip 8cb23b3181bfae3988e27d5621476e8fc74ab823
# skip: [79ff8e93eb0ddcebca4f814fc6883da8e1485c9f] source-hash-0bca15197461f9e0c6f28ce301c2fed2ec4b38cb
git bisect skip 79ff8e93eb0ddcebca4f814fc6883da8e1485c9f
# skip: [6b6b50cddd82bdfd45433bb7f8b31663211e2e13] source-hash-c3ef735fd5d8866c8ce28b89744150e733087427
git bisect skip 6b6b50cddd82bdfd45433bb7f8b31663211e2e13
# bad: [91460ba3ce3a0efa5693f098c1072b058903a31c] source-hash-69f61526cd4268a330be1e835e9e52f9b1dbde50
git bisect bad 91460ba3ce3a0efa5693f098c1072b058903a31c
# skip: [ae627c725e93b01ef68cf242574f40eb9885e3c9] source-hash-2ee4a04d61de32003d1895ac157ae97db7dd36c8
git bisect skip ae627c725e93b01ef68cf242574f40eb9885e3c9
# only skipped commits left to test
# possible first bad commit: [91460ba3ce3a0efa5693f098c1072b058903a31c] source-hash-69f61526cd4268a330be1e835e9e52f9b1dbde50
# possible first bad commit: [79ff8e93eb0ddcebca4f814fc6883da8e1485c9f] source-hash-0bca15197461f9e0c6f28ce301c2fed2ec4b38cb
# possible first bad commit: [a043626b542eb8314218d7439534dce2fc325304] source-hash-9379a922c07df3cdb7d567cc88dfaaa39ead3681
# possible first bad commit: [ae627c725e93b01ef68cf242574f40eb9885e3c9] source-hash-2ee4a04d61de32003d1895ac157ae97db7dd36c8
Comment 9 Robinson Tryon (qubit) 2015-12-13 11:10:59 UTC Comment hidden (obsolete)
Comment 10 Maarten Bosmans 2016-09-28 18:52:38 UTC
I could not reproduce this with LO 5.2 on Linux.
Can you confirm that the problem is gone?
Comment 11 Buovjaga 2016-09-28 18:58:43 UTC
Yep, seems gone.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: 7cf444454c0c27e2f6d764164ea880b87163f45a
CPU Threads: 8; OS Version: Linux 4.7; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on September 27th 2016