Bug 87070 - 4.3 releases do not launch after install on Win 7 and 8.1 x64 - soffice.exe application error (0xc000007b)
Summary: 4.3 releases do not launch after install on Win 7 and 8.1 x64 - soffice.exe a...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2014-12-07 10:36 UTC by Jan Krumrey
Modified: 2015-02-08 21:00 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:

Download link to install log file. (90 bytes, text/plain)
2014-12-07 21:02 UTC, Jan Krumrey
LO soffice.exe Dependency Walker csv export file (91.25 KB, text/plain)
2014-12-15 20:19 UTC, Jan Krumrey
Dependency Walker "swriter.exe" log (45.75 KB, text/plain)
2015-01-20 23:35 UTC, buggy_man

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Krumrey 2014-12-07 10:36:53 UTC
When I install Libre Office on my Windows 8.1 64-Bit system, the application does not launch after a supposedly successful install, not even after a system restart. Instead the following error message is displayed:

"soffice.exe - Anwendungsfehler

Die Anwendung konnte nicht korrekt gestartet werden (0xc000007b).
Klicken Sie auf "OK", um die Anwendung zu schließen."

This has happened on all 4.3 releases I have tried so far, while works without problems.
Comment 1 V Stuart Foote 2014-12-07 17:27:00 UTC

With that (0xc000007b) error I would suspect a missing/mis-configured MS Visual C++ Runtime.  You don't have Visual Studio installed do you?

The Runtime for VS 2012 u4 (the LO 4.3 release builds are built with VS 2012)

A reinstall of the VS 2012 runtime may help.

Otherwise, a few questions please.

1.) for each downloaded version of a 4.3 build, have you verified the HASH value of the download against the published Mirror list details?
That is, are you certain you have had complete and non-corrupt installer(s)? Calculating the HASH value is easily done but with Windows you'll need a 3rd party app.

2.) have you done a complete removal of the LibreOffice user profile, and then an uninstall of LibreOffice, followed by Windows registry cleaning and a restart, and then run the install?

3.) what local (language & country) is you OS configured for? Are you selecting additional configurations during a custom install?
For example:
en-US   1033
de-at   3079
de-de   1031
de-li   5127
de-lu   4103
de-ch   2055

4.) when running the installer are you doing so "Run as Administrator", or having activated the Administrator account?

5.) could you capture an installation log? Open a Windows command (Find cmd.exe and Run as Administrator) and enter "msiexec.exe /i LibreOffice_4.3.5.1_Win_x86.msi /L*v install.log", perform you installation as usual, and then zip the log and post it for us to review?
Comment 2 Jan Krumrey 2014-12-07 21:02:09 UTC
Created attachment 110545 [details]
Download link to install log file.
Comment 3 Jan Krumrey 2014-12-07 21:03:13 UTC
Thanks Stuart,

I do not have Visual Studio installed. I have both C++ 2008 Redistributable (x64) and (x86) Version 9.0.30729.6161 installed. Unfortunately, the problem persist after installing the Visual C++ Redistributable 2012 11.0.61030 you linked to.

1.) The MD5 checksum of the downloaded installer is identical to the one posted on the Libreoffice download site (940ba10821c75e9671c350f6fef17839).

2.) I have not tried that yet, and would prefer to avoid it if possible.

3.) German/Germany. I did not select additional configurations during a custom install.

4.) I run the installer using the administrator account, not "Run as Administrator".

5.) I send the log file via Wetransfer to your email adress, as it's bigger than 3 MB and cannot be attached even after zipping., I changed the file name to "LibreOffice_4.3.4_Win_x86.msi" but otherwise followed your instructions.
Comment 4 V Stuart Foote 2014-12-07 23:35:56 UTC

OK, had a look through the installer log and nothing jumps out as an issue.

You might go ahead and perform Administrative /a installation in parallel (using its own user profile) and verify that there is no OS issue preventing LibreOffice from running.


Beyond that, I do think you will need to back up your user profile, and completely clean the system of LibreOffice, and then reinstall. Go ahead and use the build from the pre-release site. http://dev-builds.libreoffice.org/pre-releases/win/x86/  , or maybe even the 4.4.0.beta2

Wish we could be more helpful.
Comment 5 Urmas 2014-12-13 05:33:52 UTC
Try to install VS 2013 32-bit redistributable. (v12)
Comment 6 V Stuart Foote 2014-12-13 14:30:15 UTC
(In reply to Urmas from comment #5)
> Try to install VS 2013 32-bit redistributable. (v12)
Good thought, but 4.3 and 4.4 branches will remain on VS 2012, just current master (4.5) onward will be VS 2013 and require that runtime.

@Jan, any luck saving profile (or just deleting it) and doing a clean installation? Or, did a /A install run for you?
Comment 7 Jan Krumrey 2014-12-14 13:24:07 UTC
@ Stuart
I tried a parallel install of "LibreOffice_4.3.4_Win_x86.msi" using the "msiexec /a" command and changed the "UserInstallation=" entry in bootstrap.ini of the parallel installation to "$ORIGIN/..", but I am still getting application error (0xc000007b) when I try to run soffice.exe. This is with C++ Redistributable 2012 (x86) 11.0.61030 installed. MD5 of installation file is identical to the one on the mirror list.

Thanks for your help. -JK
Comment 8 Jan Krumrey 2014-12-14 13:40:12 UTC
@ Urmas

I installed C++ 2013 X86 V12.0.21005 in addition to C++ 2012 X86 and installed LO V4.3.5.1 in parallel (MD5 Hash matched) but still got application error (0xc000007b) when trying to run soffice.exe.
Comment 9 Jan Krumrey 2014-12-14 14:02:29 UTC

I backed up and deleted my main installation's user profile, uninstalled LibreOffice, cleaned the registry with CCleaner 5, used System Control to delete temporary files, restarted, and installed LO 4.3.4 anew, but the problem persists. This is with only C++ 2012 X86 V11 installed on the system.

Back to 4.2.8 which works perfectly, as do all other versions of 4.2. I never had this problem before.
Comment 10 V Stuart Foote 2014-12-14 16:08:47 UTC

OK, sorry this is a hassle for you. You're doing the correct steps to trouble shoot, including cleanups and attempting to run the /A administrative install in parallel.

I run these myself on 8.1 so I know the TB and release builds do function on Windows 8.1--either fully installed or in parallel.

Please check, for the failled runs, are there any additional details in the error messages, other than the (0xc000007b)?  Reviewed in the Event Viewer -> Windows Logs, on either Application or System tab.

Then next thing to check, simply activate the built-in Administrator account and login with it?  Done easily from a cmd window "run as administrator" issue "net user administrator /active:yes". To revert later, rerun with "/active:no", but if you are going to leave it active set a password.

Doing that, will the earlier /A administrative installs run with that privileged account?

Comment 11 Jan Krumrey 2014-12-14 18:18:01 UTC

In the event viewer, under the application tab there are two error messages, here is the first in XML view:

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="0">1000</EventID> 
  <TimeCreated SystemTime="2014-12-14T17:56:53.000000000Z" /> 
  <Security /> 
- <EventData>
  <Data /> 
  <Data /> 
And here the second:

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="49152">1005</EventID> 
  <TimeCreated SystemTime="2014-12-14T17:56:53.000000000Z" /> 
  <Security /> 
- <EventData>
  <Data /> 
Comment 12 Jan Krumrey 2014-12-14 18:22:10 UTC
I also activated the built-in administrator account and logged in with it, but I still get the (0xc000007b) application error popup when I try to run soffice.exe of the parallel install.

Thanks again for your help.
Comment 13 V Stuart Foote 2014-12-14 20:35:28 UTC

OK. So we know the issue is not permissions.

This is a 64-bit Windows 8.1 install, with 1031 de-DE localization.

Also, the NTDLL.DLL being called is the 64-bit one in C:\Windows\system32, rather than the 32-bit from C:\Windows\SysWOW64, that seems odd--but it could be normal for language support.

Do you have a NLSPATH variable set?  You would check from command window with "set", or "env" commands.

Also, the builds you show in the error for the NTDLL.DLL are more current than I have patched at the moment.

Ntdll.dll 6.3.9600.17476 1,733,952 30-Oct-14 5:41 x64
Ntdll.dll 6.3.9600.17476 1,499,384 30-Oct-14 5:47 x86

I am working with the NDLL.DLL version 6.3.9600.17278 from 15-Aug-2014, unfortunately I can not update them remotely so will have to wait until I get in to work tomorrow to run http://support.microsoft.com/kb/3013769 updates and will test again to see if that somehow is causing the problems.

Comment 14 Jan Krumrey 2014-12-14 20:47:08 UTC
@ Stuart

There's no NLSPATH variable listed under system properties/advanced/environment variables, so I assume it's not set?
Comment 15 V Stuart Foote 2014-12-15 18:41:31 UTC

Sorry to say that with a 64-bit en-US install of Windows 8.1 Enterprise with the KB3013769 roll-up installed I can simply not reproduce the issue with either full, or /A administrative, installs of LibreOffice, (or now pre-release).  As well, 4.4.0 beta2 and current masters all run.

I'm guessing there could be something strange in system path on your de-DE install that is pushing 64-bit ahead of 32-bit libraries. A run with Dependency Walker (http://dependencywalker.com/) might let you tease it out.

@Jesús, Andras, Fridrich -- any of you working yet in 8.1 (or 10) and having anything similar to this with your localizations and LibreOffice?

Comment 16 Jan Krumrey 2014-12-15 20:19:21 UTC
Created attachment 110879 [details]
LO soffice.exe Dependency Walker csv export file

I ran Dependency Walker on the parallel install soffice.exe and it found the following errors:

Error: At least one required implicit or forwarded dependency was not found.
Error: Modules with different CPU types were found.
Warning: At least one delay-load dependency module was not found.
Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

I "saved as..." a csv file and attached it.
Comment 17 buggy_man 2015-01-20 23:35:45 UTC
Created attachment 112569 [details]
Dependency Walker "swriter.exe" log

I have faced same issue with all LO above 4.3, even pre ones on Win7 x64.

Attached dependency walker "swriter.exe" log.

I did install one of problem version in parallel to working 4.2.8 too as wiki says.
Comment 18 Jan Krumrey 2015-02-08 20:37:41 UTC
Just a quick update: I ran sfc /scannow and it found some unrepairable system files. I reinstalled Windows, and LO is now working.
Comment 19 V Stuart Foote 2015-02-08 21:00:16 UTC
(In reply to Jan Krumrey from comment #18)
> Just a quick update: I ran sfc /scannow and it found some unrepairable
> system files. I reinstalled Windows, and LO is now working.

Sorry that it came to that--MS Windows is not very forgiving for users when configurations go wonky and doing a SFC can't clear things up. Data/applications back-up and reinstall is drastic--but sometimes the only path forward.

Thank you though for taking the time to close this issue out.