Download it now!
Bug 87077 - 4.4.0.beta2 on OSX shows truncated? locale info in About window
Summary: 4.4.0.beta2 on OSX shows truncated? locale info in About window
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta1
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-07 17:57 UTC by Martin Srebotnjak
Modified: 2015-08-01 07:17 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2014-12-07 17:57:55 UTC
The 4.4.0.beta2 with Slovenian language pack on OSX shows the locale in the About window, but for Slovenian as locale string "sl_" is shown, which either means that "sl_SI" was meant to be displayed so the string got truncated or "sl" was meant to be seen, so it should be truncated more?

Probably this should be tested with other locales and their identifiers of different length.
Comment 1 retired 2014-12-08 10:18:43 UTC
This is interesting. In LO Version: 4.5.0.0.alpha0+
Build ID: a26222f5af55e8ffe9784dd411485d3c5c72e983
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2014-12-07_00:14:47
Locale: de_

I do see "de_" but this is the nightly "as is" no language pack installed. So maybe this is the region? However your point persists and is valid.

NEW
Comment 2 Martin Srebotnjak 2015-03-31 00:09:46 UTC
I can confirm that with 4.4.2 RC2 on OS X I see only "sl_", whereas the same Windows version shows "sl_SI", so it seems OS related bug, as reported.
Comment 3 Martin Srebotnjak 2015-07-28 13:03:38 UTC
It seems to be corrected with LO50RC4, now it writes:
sl-SI (sl.UTF-8)

So I am closing this as WORKSFORME.
Comment 4 Adolfo Jayme 2015-08-01 07:17:01 UTC
This got fixed with http://cgit.freedesktop.org/libreoffice/core/commit/?id=f318e305b6afa715ef759b8589823da53b812a88 since April.