Bug Hunting Session
Bug 87113 - save as -dialog acts as open file dialog [Hard to reproduce]
Summary: save as -dialog acts as open file dialog [Hard to reproduce]
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-08 19:04 UTC by Wolf jung
Modified: 2016-10-10 11:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolf jung 2014-12-08 19:04:47 UTC
Suppose I have  a.odt  and  b.doc  in some directory.
I open  a.odt  and click  save as  to convert it to  a.doc .
However,  when I choose  doc  from  the pull-down list,  the file name is changed from   a.odt  to  b.doc  instead of  a.doc .  If I do not notice this,  the unrelated file  b.doc  will be overwritten with the converted  a.odt  without a warning.

The reason seems to be that the file dialog is looking for an existing  *.doc  file instead of creating a new file with the same base name and a different ending.
Comment 1 Joel Madero 2014-12-09 01:33:39 UTC
LibreOffice 4.3.3.2 release
Ubuntu 14.04 x64

I do not see this behavior if I am understanding you correctly. What I did:

Repro Steps: 

1. New document;
2. Save as a.odt in folder temp;
3. New document;
4. Save as b.doc in folder temp;
5. Close LibreOffice;
6. Open a.odt
7. File -> Save As -> Pull Down menu .doc

You Observe:
File a.odt changes to b.doc?

I observe:

Extensions aren't even visible - I just see "a" and the extension is controlled by the drop-down.

Am I missing something? Setting to NEEDINFO as the instructions provided are a bit unclear. Once you provide reproducible steps please set to UNCONFIRMED. Thanks!
Comment 2 Wolf jung 2014-12-09 20:59:11 UTC
(In reply to Joel Madero from comment #1)
These steps are precisely what I meant.  I tried again on 2 systems and it is confusing:

* With LO 4.2.5.2 on Windows 7 the problem does not happen;  the ending is not shown at all but the new file is correct.

* With LO 4.1.6.2 on Suse Linux,  the problem does not happen in this way in a new directory.  The endings are shown,  sometimes  a.odt  is replaced with an empty string upon choosing doc,  sometimes  a.doc  comes correctly.

* In my Downloads directory with 2000 files and hundreds of  odt  and  doc , the problem happens consistenly:  for several  odt  files that I tried, the conversion always is changing the file's base name to an existing  doc  file.
The problem does not happen for conversion from  doc  to  odt .

* So I copied all  doc  and  odt  files to a new directory,  but here the problem does not appear ...
Comment 3 steve -_- 2016-01-09 00:29:31 UTC
Is this bug still valid / reproducible with the latest LO release?
http://www.libreoffice.org/download/libreoffice-fresh/

Should this be still reproducible for you with the latest LO release please set this bug back to UNCONFIRMED. Should this issue be solved set it to WORKSFORME.

Setting to NEEDINFO until more detail is provided.
Comment 4 Xisco Faulí 2016-09-11 22:00:13 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2016-10-10 11:12:28 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-20161010