Bug 87146 - Formula elements too small - corrected by editing
Summary: Formula elements too small - corrected by editing
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.2.7.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-09 10:00 UTC by paour
Modified: 2019-08-15 08:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
all widehats are too small or too large (81.47 KB, image/png)
2014-12-09 10:00 UTC, paour
Details
odt document with widehat too small (170.95 KB, application/vnd.oasis.opendocument.text)
2014-12-09 10:02 UTC, paour
Details
PDF with widehat too small (no change) (116.79 KB, application/pdf)
2014-12-09 10:05 UTC, paour
Details
Widehat too large (and too small 2nd page) (196.58 KB, application/pdf)
2014-12-09 10:12 UTC, paour
Details
Wrong widehat position before and correct position after editing formula (19.74 KB, image/png)
2017-06-28 16:39 UTC, paour
Details
Wrong widehat position before editing formula (22.00 KB, application/vnd.oasis.opendocument.text)
2017-06-28 16:40 UTC, paour
Details
Correct position after editing formula (22.00 KB, application/vnd.oasis.opendocument.text)
2017-06-28 16:40 UTC, paour
Details

Note You need to log in before you can comment on or make changes to this bug.
Description paour 2014-12-09 10:00:15 UTC
Created attachment 110612 [details]
all widehats are too small or too large

Hello,
I read this bug (widehat crop : https://bugs.freedesktop.org/show_bug.cgi?id=62355), but my problem seems different.
----------------------------------------------
Libreoffice Version: 4.2.7.2
Build ID: 933c0aa564ec4f8883ed5732c866db48dca4dac5
OS : Win XP SP1 - Win 7 SP1 - Win 8.1 SP1
---------------------------------------------
The widehat preview is "sometime" different when I reopen my documents.
This problem is not regular and occur on the same machine, or when I exchange my documents with other computer (IE: Win XP SP1 - Win 7 SP1 - Win 8.1 SP1).
If I save the document in PDF, the preview is already wrong

Some time the widehat is too small (see attach widehat.png)

Some time the widehat is too large (see attach widehat.png)
Regards
Nicolas
Comment 1 paour 2014-12-09 10:02:21 UTC
Created attachment 110613 [details]
odt document with widehat too small

First example odt document with widehat too small
Comment 2 paour 2014-12-09 10:05:50 UTC
Created attachment 110614 [details]
PDF with widehat too small (no change)

The same document converted in PDF
Comment 3 paour 2014-12-09 10:12:47 UTC
Created attachment 110616 [details]
Widehat too large (and too small 2nd page)

Second example : PDF document (I have corrected my original odt doc) whit too large widehat (bottom of the first page)
(sorry for my English, I'm French)
Comment 4 paour 2014-12-09 10:20:33 UTC
To sum up, If I edit (double-click) the widehat, formula is correct (ie: widehat {"BAC"}). And after come back in the doc, widehat is correct.
I need to correct all my documents each day
Nicolas
Comment 5 tommy27 2014-12-10 05:18:58 UTC
hi, would you please post a minimal test case, with just a single widehat where you can constantly reproduce the bug? 

the simpler the document is, the easier will be to spot the differences and focus on the issue.

a comparative screenshot showing the desired width of the widehat would be useful too.

moreover I did not understand if you are complaining about a visualization bug in the .odt file or just in the .pdf export.

also consider upgrading to LibO 4.3.4.1 and retest with that version.

set status to NEEDINFO
revert it to UNCONFIRMED once you give required informations
Comment 6 paour 2014-12-10 16:06:24 UTC
Hello,
>moreover I did not understand if you are complaining about a visualization bug
>in the .odt file or just in the .pdf export.

I'm complaining about a visualization bug in the .odt file 
Nicolas
Comment 7 QA Administrators 2015-06-08 14:28:35 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2015-07-18 17:27:13 UTC Comment hidden (obsolete)
Comment 9 paour 2017-06-28 16:39:29 UTC
Created attachment 134356 [details]
Wrong widehat position before and correct position after editing formula
Comment 10 paour 2017-06-28 16:40:12 UTC
Created attachment 134357 [details]
Wrong widehat position before editing formula
Comment 11 paour 2017-06-28 16:40:40 UTC
Created attachment 134358 [details]
Correct position after editing formula
Comment 12 paour 2017-06-28 16:44:06 UTC
Hello,
I already have this problem since 3 years :(

Libreoffice version : Version: 5.3.4.2 (x64) 
Please find attach the screens shots:
1- "widehat position.png" -> Wrong widehat position before and correct position after editing formula
2- "before.odt" -> Wrong widehat position before editing formula
3- "after.odt" -> Correct position after editing formula

This problem happens regularly randomly
Many Thanks
Nicolas
Comment 13 Bernard SIAUD 2017-06-28 17:13:48 UTC
I think that I have a similar problem.

Sometime, when I work with a hold document, my formula are to small when I reopen my documents.
If I edit (double-click) formula is correct.

I work with windows at work and Linux at home.
Comment 14 Buovjaga 2017-06-29 19:27:36 UTC
(In reply to paour from comment #4)
> To sum up, If I edit (double-click) the widehat, formula is correct (ie:
> widehat {"BAC"}). And after come back in the doc, widehat is correct.
> I need to correct all my documents each day
> Nicolas

Yep, confirmed with attachment 110613 [details].

But it stays correct after save and reload..

I think there is another report for this, but I could not find it.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: 98befbb26217b0bf3f35354e418a355280c52cfc
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 29th 2017
Comment 15 QA Administrators 2018-07-25 02:40:34 UTC Comment hidden (obsolete)
Comment 16 paour 2018-07-31 12:38:30 UTC
Hello,
This bug already exist with :
Version: 6.0.5.2 (x64)
Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
Threads CPU : 2; OS : Windows 6.3; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: group
Regards
Nicolas
Comment 17 QA Administrators 2019-08-01 03:36:28 UTC Comment hidden (obsolete)
Comment 18 paour 2019-08-15 07:53:29 UTC
No problem between new versions of Libreoffice.
I decided to close this ticket even if the probleme exist between the document gave as example and the last version of Libreoffice
Comment 19 Xisco Faulí 2019-08-15 08:26:21 UTC
(In reply to paour from comment #18)
> No problem between new versions of Libreoffice.
> I decided to close this ticket even if the probleme exist between the
> document gave as example and the last version of Libreoffice

Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.