Download it now!
Bug 87149 - black boxes instead of images opening visio 2007 file
Summary: black boxes instead of images opening visio 2007 file
Status: RESOLVED DUPLICATE of bug 73523
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2014-12-09 10:46 UTC by Daniel
Modified: 2015-02-01 12:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
black boxes where images are supposed to be (116.32 KB, image/jpeg)
2014-12-09 10:46 UTC, Daniel
Details
visio file with images (1.11 MB, application/vnd.visio)
2014-12-09 13:37 UTC, Daniel
Details
console logs (743.36 KB, text/plain)
2014-12-09 20:29 UTC, Julien Nabet
Details
bt (2.16 KB, text/plain)
2014-12-09 20:44 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2014-12-09 10:46:42 UTC
Created attachment 110620 [details]
black boxes where images are supposed to be

when opening a visio 2007 file images are replaced with black boxes.
opening the same visio file in internet explorer displays the images correctly
Comment 1 raal 2014-12-09 11:40:01 UTC
Hello,

Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 2 Daniel 2014-12-09 13:37:47 UTC
Created attachment 110628 [details]
visio file with images
Comment 3 Julien Nabet 2014-12-09 20:29:13 UTC
Created attachment 110643 [details]
console logs

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 4 Julien Nabet 2014-12-09 20:31:16 UTC
Fridrich/Valek: one for you? (I attached detailed debug console)
Comment 5 Julien Nabet 2014-12-09 20:44:56 UTC
Created attachment 110647 [details]
bt

First bt caught thanks to this:
catch throw EndOfStreamException
Comment 6 Valek Filippov 2014-12-10 00:21:40 UTC
Fridrich,

the black boxes are at the places of the shapes which are actually embedded bitmaps. The only a bit unusual thing I see about those is 'compression method = 3' (DIB header).
OLEToy seems to handle them well, you can try 
0:2:11:1:1:1:1
$dib@13

I've dumped picture from OLEToy, whatever version of LO Draw I have were able to open it properly.
Comment 7 David Tardon 2015-02-01 12:25:25 UTC

*** This bug has been marked as a duplicate of bug 73523 ***