Bug 87153 - Named Range Reference Updated After Deletion of Data
Summary: Named Range Reference Updated After Deletion of Data
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-09 13:18 UTC by dmdcomputing
Modified: 2016-04-19 05:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Spreadsheet containing data to reproduce the error (53.61 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-12-09 13:18 UTC, dmdcomputing
Details
Data to reproduce the error (53.61 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-12-09 13:26 UTC, dmdcomputing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dmdcomputing 2014-12-09 13:18:45 UTC
Created attachment 110625 [details]
Spreadsheet containing data to reproduce the error

The references of a named range are updated after the deletion of data in a different named range in a separate worksheet.

The attached file contains two sheets: 'Books' and 'Authors'.

The first sheet contains the names of the authors and books plus the book source; a formula calculates the number of books and there is a range name ('EbooksAuthors'), which starts at the 'Author' row and finishes on the 'Dummy Data' row.

The second sheet contains a list of the authors along with calculations for the number and percentage of books for each author. The number of books formula uses COUNTIF and its range is 'EbooksAuthors'. There are also calculations for the number of authors and the total books. The range name 'AuthorsList' covers the table, starting at the heading row and finishing at the 'Dummy Data' row.

Steps to reproduce:
1. In the 'Books' sheet, delete an entry for 'Belloc Lowndes, Marie'.
2. Switch to the 'Authors' sheet (where you may see that a COUNTIF bug means the number of books for 'Belloc Lowndes, Marie' has not been updated and causes errors).

Current behaviour:
Select the range name 'AuthorsList' and you will see the highlighted range has been reduced by one row.

Expected behaviour:
The references for the range name 'AuthorsList' should be unchanged.


(Saving and reopening the file will update the COUNTIF formula for 'Belloc Lowndes, Marie' but the range name reference remains incorrect.)

Please note: when two entries for entry 'Belloc Lowndes, Marie' are deleted together in the 'Books' sheet, the COUNTIF functions in the 'Authors' sheet updates but the range name 'AuthorsList' is reduced by two rows.
Comment 1 dmdcomputing 2014-12-09 13:26:35 UTC
Created attachment 110626 [details]
Data to reproduce the error
Comment 2 GerardF 2014-12-09 19:41:39 UTC
What do you mean by "1. In the 'Books' sheet, delete an entry ...."
* delete the data?
* delete row?
Comment 3 dmdcomputing 2014-12-10 07:57:03 UTC
(In reply to GerardF from comment #2)
> What do you mean by "1. In the 'Books' sheet, delete an entry ...."
> * delete the data?
> * delete row?

Apologies. I mean delete the row.
Comment 4 QA Administrators 2015-12-27 20:31:56 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 5 dmdcomputing 2015-12-28 09:12:51 UTC
As far as I can tell, I have already supplied all the necessary information.

Having said that, I could not reproduce the bug in version 5.0.4.2.
Comment 6 mahfiaz 2016-04-19 05:35:56 UTC
Thanks for reporting back. If you say it works in a newer version, then it's safe to mark this as resolved, worksforme.