Download it now!
Bug 87204 - FILESAVE: PowerPoint pps causes LO to crash or freeze...
Summary: FILESAVE: PowerPoint pps causes LO to crash or freeze...
Status: RESOLVED DUPLICATE of bug 102688
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: GDI-Limit
  Show dependency treegraph
 
Reported: 2014-12-10 19:20 UTC by gooly
Modified: 2017-05-03 12:16 UTC (History)
7 users (show)

See Also:
Crash report or crash signature: ["SalFrame::SetCallback(vcl::Window *,bool (*)(vcl::Window *,SalEvent,void const *))"]


Attachments
problematic document (2.42 MB, application/vnd.ms-powerpoint)
2015-09-16 11:01 UTC, Xisco Faulí
Details
debug from procdump dump (10.20 KB, text/plain)
2017-01-26 08:37 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gooly 2014-12-10 19:20:27 UTC
Hi, 
wanted to load and save this Excel-presentation:
http://www.statistik.tu-dortmund.de/~fried/RobusteVerfahren/0-Einleitung.pps
and LO crashes as soon as I want to save it as LO-presentation.
Comment 1 raal 2014-12-10 20:28:34 UTC
I can confirm crash with LO 4.3.4, win7.

I can confirm crash Version: 4.5.0.0.alpha0+
Build ID: 31e8084fc07c3de09230c0f0c6ed947b3de98df1
TinderBox: Win-x86@42, Branch:master, Time: 2014-12-07_06:59:33

Can not reproduce on Linux.
Comment 2 Xisco Faulí 2015-09-16 11:01:44 UTC
Created attachment 118766 [details]
problematic document

This issue is still present in

Version: 5.0.1.2
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 3 Julien Nabet 2015-11-18 22:15:21 UTC
If someone still reproduces it on Windows with last stable LO version 5.0.3, any chance for a bt?
Comment 4 fiftyigfuci_f_mi 2016-12-11 02:32:19 UTC
I opened the comment#2 file then a slideshow started automatically.
I manually quit the slideshow then the show ended and after a while, Impress was killed automatically.
It's not my expected result.

My dev build:
Version: 5.4.0.0.alpha0+
Build ID: f35d29c8388744be1f95ec4acfca12eec706911a
CPU Threads: 2; OS Version: Linux 4.9; UI Render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 5 Julien Nabet 2017-01-13 22:15:26 UTC
(In reply to fiftyigfuci_f_mi from comment #4)
> I opened the comment#2 file then a slideshow started automatically.
> I manually quit the slideshow then the show ended and after a while, Impress
> was killed automatically.
>...

It could be interesting to retrieve a bt (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace).
Indeed, it might be a dup of tdf#105188
Comment 6 Timur 2017-01-17 12:30:26 UTC
The crash report was successfully uploaded.
crashreport.libreoffice.org/stats/crash_details/17b8cefb-de2f-4bd7-bcf3-4d741ca24cb2
Filed at least for Bug 105118 and Bug 105376.
Comment 7 Timur 2017-01-17 12:32:50 UTC
*** Bug 105376 has been marked as a duplicate of this bug. ***
Comment 9 Xisco Faulí 2017-01-17 12:46:38 UTC
(In reply to Timur from comment #8)
> Similar reports (a lot!):
> http://crashreport.libreoffice.org/stats/signature/SalFrame::
> SetCallback%28vcl::Window%20*,bool%20%28*%29%28vcl::Window%20*,SalEvent,
> void%20const%20*%29%29

Raising severity and priority! Thanks for triaging this.
Comment 10 Timur 2017-01-17 12:58:16 UTC
Crash repro with 4.1, not with 4.0.5 (although it was slow) for attachment 118766 [details]. I'll mark as regression so far. I didn't test Stefan's attachment 130483 [details] and steps from Bug 105376 nor Bug 105118.
Comment 11 Stefan_Lange_KA@T-Online.de 2017-01-17 20:16:40 UTC
Because of the hint to Bug 105118 (GDI problem) I have made new tests with the spreadsheet document "Test_Comment_Crash.ods" attached to Bug 105376.

Result: I think that the first "Save" or "Autosave" creates very much GDI objects.

First I have increased the GDI quote in Windows from 10000 to 60000 to prevent the crashes (and reatarted the system to activate the change). A new test with my document gave no crash (but after document was saved and LO should be closed, shutdwon of LO was hanging - see bug 105055). 

Then I have "installed" Nirsoft GDIView to see the GDI objects counter at further tests.

The counters I have seen at the several tests were not exactly the same, but they were in the same ranges always. The figures below are from one of the tests. 

When the document was opened and I had navigated to the first sheet ("Altix I bis III") the GDI counter ("All GDI") was 125. After the four first comments were inserted and before the document was saved the GDI counter was 255.
This means that every comment has increased the counter by 27 or 28, although the comments are hidden. I don't if this correct or not. Because the comments are not shown I think only the bitmanp counter should be increased by 1. 

While the document was saved the GDI counter has extremly increased from 255 to 9873!!!

After some additional comments have been inserted the old limit of 10.000 was exceeded.

Interestingly:
- Only at the first save (or maybe also Autosave) the GDI counter increases extremly. At additional saves the counter has not increased or increased only slightly. 
- At "Undo" the GDI counter does not decrease and at "Redo" it does not increase.

These tests were made with LO 5.3.0.2 (x64).
Comment 12 Kohei Yoshida 2017-01-26 02:29:21 UTC
I've tested this with a build that contains fix for Bug 103927, and I can't reproduce the crash.
Comment 13 Timur 2017-01-26 08:37:02 UTC
Created attachment 130689 [details]
debug from procdump dump

Confirm. No crash and saving as before, slow. 
I'd kindly ask Stefan to test all those before closing. 
But, I get dump with procdump with error cppu3.dll!uno_type_equalData.
Should that be considered the same bug?
Comment 14 Kohei Yoshida 2017-01-26 12:57:03 UTC
(In reply to Timur from comment #13)
> Created attachment 130689 [details]
> debug from procdump dump
> 
> Confirm. No crash and saving as before, slow. 
> I'd kindly ask Stefan to test all those before closing. 
> But, I get dump with procdump with error cppu3.dll!uno_type_equalData.
> Should that be considered the same bug?

No. I'd treat that as a different issue.
Comment 15 Stefan_Lange_KA@T-Online.de 2017-01-26 14:12:52 UTC
Test with
Version: 5.4.0.0.alpha0+
Build ID: b41186a2fc49e440890b8c86e5367352ffaf9cd6
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-26_01:50:40
Locale: de-DE (de_DE); Calc: group

First I have tested only the duplicate Bug 105376:

Result:
No crashes, GDI counter increases only slightly while file was saved. OK!

But I have seen in GDIView, that GDI counter fast increases when sheet is edited. First I have thougt that this is related to insert of comments. But then I have seen that GDI counter also increases when cells ar selected by mouse click and also only by scrolling in the document.  Finally it exceeds the limit and LO crashes. See also Comment 13 in Bug 102688!

After this I have tried to open at the same time the attached documents from Bug 102688 (2x ods), from Bug 105118 (foo.odp) and from Bug 87204 (0-Einleitung.pps).

Depending on the sequence how documents were opened there were several problems. I have not analized completely until now.
Comment 16 Julien Nabet 2017-01-26 14:20:32 UTC
Caolán/Khaled: thought you might be interested in this one since gdi is related to fonts rendering (not only) so vcl part.
Comment 17 Kohei Yoshida 2017-01-27 20:47:21 UTC
There is lots of duplicate communication going on here. I'll close this as duplicate.

*** This bug has been marked as a duplicate of bug 102688 ***