Download it now!
Bug 87228 - Data series changes require confirmation for each change
Summary: Data series changes require confirmation for each change
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: IA64 (Itanium) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-12-11 09:37 UTC by denis campbell
Modified: 2016-04-24 16:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file for testing multiple range editing (19.68 KB, application/x-zip-compressed)
2015-01-07 00:10 UTC, panoworks
Details

Note You need to log in before you can comment on or make changes to this bug.
Description denis campbell 2014-12-11 09:37:21 UTC
Libreoffice Calc 4.3.4.1

In the Data Ranges dialogue.
When editing series values it is necessary to change each series one at a time, confirming each change individually:
Change value, click OK, and re-open the Data Ranges Dialogue.
This is very tedious for charts with multiple series.

In previous versions this was not necessary - you edited all series one after the other then confirmed all the changes in one click.

I cannot see any reason for this change, so I am assuming it is a bug.
Comment 1 Joel Madero 2014-12-12 05:27:55 UTC
Hi Again :)

Again going to place this into NEEDINFO.

Here please do the following:
1. Attach a simple document that we can see the issue;
2. Provide clear enumerated steps on how to reproduce.

Despite years on the project, no one on QA knows everything about LibreOffice so it's always best to provide clear steps on how to reproduce a bug. The best way to do so is to write in enumerated list:

1. Open file;
2. Click on . . .
3. . . . 

Observed:

Expected:

Last Worked on: 

As you've said this is a regression I'll go ahead and add that now. Mark as UNCONFIRMED once you provide clear steps and a sample document.
Comment 2 panoworks 2015-01-07 00:10:32 UTC
Created attachment 111879 [details]
Sample file for testing multiple range editing
Comment 3 panoworks 2015-01-07 00:31:39 UTC
Came here to log this bug after finding this was still the case in 4.3.5.2

Attached a sample file, even though the sample file is a bit superfluous.

1. Open the sample file
2. Double-click on the chart
3. Right-click and choose "Data Ranges..."
You should see ranges for the X- and Y-Values.
4. Select the "X-Values" Data range.
5. In the "Range for X-Values" text field, change "$Sheet1.$A$2:$A$4" to "$Sheet1.$A$2:$A$5" to add the 5th row.
6. Select the "Y-Values" Data range.

Observed behavior:
At this point you should notice that the "X-Values" Data range remains "$Sheet1.$A$2:$A$4"

Expected behavior:
The range should have been set to "$Sheet1.$A$2:$A$5" at this point.

I don't know when this *last* worked.  However, I can confirm this *did* work in 4.2.4.2, and doesn't work in 4.3.2.2 .  That does leave a fair range of other versions to test.
Comment 4 denis campbell 2015-01-07 00:56:23 UTC
I don't think this is quite the issue. The issue is nothing to do with the Category (X-Axis). It concerns changes to the Y Value ranges.
 
One should be able to change all of the Y Value ranges one after the other without exiting the dialogue box. However if I do this only the last Y Value change holds.
In order to change all Y Value ranges the complete procedure must be done for each Y range, ie the last Y range change before clicking OK to exit the dialogue box.

I doubt whether it would be constructive to try and find the last version which worked, I mentioned this fact to show that what worked previously no longer does so.

In the next day ot two I will produce a simpler explanation enumerating the steps including a screenshot of each step.
Comment 5 QA Administrators 2015-09-04 02:55:52 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-09-03
Comment 6 John 2015-09-09 07:45:24 UTC
V 4.4.5.2 does not appear to have the problem.  Having just edited the Data Ranges of a Chart in a spreadsheet that previously exhibited the problem ti would appear to have been rectified.
Comment 7 denis campbell 2015-09-09 08:12:19 UTC
Thanks John, you are right. Resolved. Great job by the team - donation on the way!
Comment 8 Joel Madero 2015-09-09 15:10:00 UTC
WFM because we don't know the exact patch that fixed the issue.
Comment 9 Jean-Baptiste Faure 2016-04-24 16:41:17 UTC
Version set from description.

Best regards. JBF