Download it now!
Bug 87240 - EDITING: Query of two tables shows wrong entry after saving new data
Summary: EDITING: Query of two tables shows wrong entry after saving new data
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-11 15:14 UTC by Robert Großkopf
Modified: 2017-03-06 20:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Database with query: refreshing bug an wrong entry (4.98 KB, application/vnd.oasis.opendocument.base)
2014-12-11 15:14 UTC, Robert Großkopf
Details
Screenshot: Wrong number for new entries, failed to update row. (68.58 KB, image/png)
2014-12-11 15:16 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2014-12-11 15:14:22 UTC
Created attachment 110740 [details]
Database with query: refreshing bug an wrong entry

Open the attached database.
Open the query "Query_Multiplikation_Fields_of_two_Tables".
Add a new entry like "Anzahl" → 3, "Ware_ID" → 2.
Switch to next record by using the tabulator.
'0' appears in the field "Rechnung_ID".
Open the table "Verkauf".
No '0' appears for any "Rechnung_ID" in the table.

Could be the same reason as Bug61871.
Comment 1 Robert Großkopf 2014-12-11 15:16:47 UTC
Created attachment 110741 [details]
Screenshot: Wrong number for new entries, failed to update row.
Comment 2 Robert Großkopf 2014-12-11 15:21:01 UTC
I set this bug to new. Could confirm it on Windows-PC and here with OpenSUSE 12.3 64bit rpm-Linux with every version of LO. Tested with LO 3.3.0.beta 1, also other 3.*, 4.* and 4.3.5.1.
Comment 3 Alex Thurgood 2015-01-03 17:41:27 UTC
Adding self to CC if not already on
Comment 4 QA Administrators 2016-01-17 20:05:39 UTC Comment hidden (obsolete)
Comment 5 Alex Thurgood 2016-01-19 13:12:08 UTC
Confirming still present in
Version: 5.0.3.2
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale : fr-FR (fr.UTF-8)

OSX 10.11.2
Comment 6 QA Administrators 2017-03-06 14:46:24 UTC Comment hidden (obsolete)
Comment 7 Robert Großkopf 2017-03-06 20:14:38 UTC
Could not reproduce bug with LO 5.3.1.1, OpenSUSE 42.1 Leap, 64bit rpm Linux. So I will set this one to WORKSFORME.