Bug 87298 - Calc "Text to Columns" function adds unexpected rows to data!!
Summary: Calc "Text to Columns" function adds unexpected rows to data!!
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-14 04:12 UTC by Jimbo
Modified: 2017-01-04 23:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Data to Demo bug (79.65 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-12-14 04:12 UTC, Jimbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jimbo 2014-12-14 04:12:24 UTC
Created attachment 110831 [details]
Data to Demo bug

Steps to replicate bug... See Attatched Sheet.
1/ confirm row count in colums A and B  (8826 for each) Note Data in A and B is identical
2/ Highlight collumn B
3/ Goto Data Menu, Select “Text to Columns”
4/ Select the entire colum in that interface and select colums type “Date (DMY)”
5/ Hit OK and scroll down...
6/ NOTE: Column B has more rows now!!!
7/ Data between A and B no longer aligns as you get to the end!!
Comment 1 Urmas 2014-12-14 07:27:07 UTC
Cells with linebreaks are turned into several new cells by that feature.
Comment 2 m.a.riosv 2014-12-14 22:58:15 UTC
What is the bug?, as I know not possible keep several dates in the same cell, of course except they are text dates, like in source ranges here.
IMO the result it's fine every date in their cell.
Comment 3 QA Administrators 2015-12-20 16:09:12 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2017-01-03 19:47:04 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.1.6 or 5.2.3  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20170103