Download it now!
Bug 87336 - FILEOPEN: PPTX and DOCX import charts missing titles and wrong rotation of axis labels
Summary: FILEOPEN: PPTX and DOCX import charts missing titles and wrong rotation of ax...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta1
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-15 16:37 UTC by -pk-
Modified: 2015-04-30 20:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
PPTX (161.42 KB, application/zip)
2014-12-15 16:37 UTC, -pk-
Details
PPT displays correctly (405.50 KB, application/x-ole-storage)
2014-12-15 16:38 UTC, -pk-
Details

Note You need to log in before you can comment on or make changes to this bug.
Description -pk- 2014-12-15 16:37:40 UTC
Created attachment 110873 [details]
PPTX

I have attached a pptx and ppt saved with Powerpoint. PPT displays correctly, the PPTX has the following issues in 4.4.0.0.beta2:

- Charts are missing titles.
- Wrong rotation of vertical axis labels.
- Wrong orientation of X-axis labels and not wrapping text (causing every other label to disappear). Orientation behavior for the X-axis seems to be length dependent.

The missing legend label on the lower left chart is not really an issue. A 3rd data column was used as a spacer and this extra label confused the legend. Removing the text from the 3rd column before importing will make the legend display properly.
Comment 1 -pk- 2014-12-15 16:38:43 UTC
Created attachment 110874 [details]
PPT displays correctly
Comment 2 raal 2014-12-15 21:16:57 UTC
I can confirm with Version: 4.4.0.0.beta2+
Build ID: e1de94244c1b0419c1c3415c02381e8b7a87abe0
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-4, Time: 2014-12-14_11:45:23
Comment 3 Markus Mohrhard 2015-04-30 20:49:57 UTC
Fixed in master for 5.0.