Bug 87479 - Formula not getting calculated in libre office 4.3.4.1
Summary: Formula not getting calculated in libre office 4.3.4.1
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: All Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-19 07:32 UTC by SriJanani
Modified: 2015-10-09 20:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
formula issue (144.42 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-12-19 07:32 UTC, SriJanani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SriJanani 2014-12-19 07:32:24 UTC
Created attachment 111029 [details]
formula issue

Can you help me the issue attached. 

Attached is the ods sheet

Steps to reproduce: 

*Open the file
*Go to sheet FG Capacity
*The sheet has all linked formulaes
*The problem where values are not getting updated is at column=AD(=AC*M4)
*Column C is the input column- for example if we enter value in C column it should auto refresh all the formulas.
*Weired thing is except columnAD all the values(cell values) are getting auto refreshed.

Steps Tried: 

* File is in ODS format
* Sheet does not have any external link
* this particular sheet is created in Libre calc
* Recalculate and auto recalculate not work
* Hard Recalculate ctrl+shft+f9 also does not work
* Deleted and readded the sheet does not work
* Deleted/inserted column does not work

Please advice.

Regards,
SriJanani
Comment 1 m.a.riosv 2014-12-20 01:15:05 UTC
Hello SriJanani,

Thank you for reporting the bug. To be certain the reported issue is not related to corruption in the user profile, could you rename this LibreOffice user directory ( see https://wiki.documentfoundation.org/UserProfile#Default_location or http://ask.libreoffice.org/en/question/903/where-are-the-libreoffice-data-profile-files/ ) and re-test?

I think works fine for me. if I put 250 in C4, AC4 change to 9.
Cells have rounded format so is necessary change in the input cell value enough to change the result.
Comment 2 aaker 2015-01-03 23:40:20 UTC
SriJanani

I assume your formula in "AD" is working as expected. Substituting al the refs by the appropriate values, you will get "=O4/C4*20*(((C4*(1+E4))*(1+H4))*(1+K4))/20".
Multiplying and subsequent dividing by 20 cancels out:
"=O4/C4*(((C4*(1+E4))*(1+H4))*(1+K4))"
Normalizing with the brackets you will get
"=O4/C4*C4*(1+E4)*(1+H4)*(1+K4)"
Once more dividing and subsequent multiplying by "C4" cancels out.
So changing the value in "C4" will change nothing to the result of your formula in "AD4".

cheers
Markus
Comment 3 aaker 2015-01-04 11:29:20 UTC
(In reply to aaker from comment #2)
> SriJanani
> 
> I assume your formula in "AD" is working as expected. Substituting al the
> refs by the appropriate values, you will get
> "=O4/C4*20*(((C4*(1+E4))*(1+H4))*(1+K4))/20".
> Multiplying and subsequent dividing by 20 cancels out:
> "=O4/C4*(((C4*(1+E4))*(1+H4))*(1+K4))"
> Normalizing with the brackets you will get
> "=O4/C4*C4*(1+E4)*(1+H4)*(1+K4)"
> Once more dividing and subsequent multiplying by "C4" cancels out.
> So changing the value in "C4" will change nothing to the result of your
> formula in "AD4".
> 
> cheers
> Markus

Verify proper calculation of formula by changing value in "O4"
Comment 4 QA Administrators 2015-07-18 17:35:06 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-07-18
Comment 5 m.a.riosv 2015-08-23 22:42:17 UTC
Please @SriJanani, is the issue solved?