Bug 87487 - Vlookup 504 error
Summary: Vlookup 504 error
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-19 11:46 UTC by SriJanani
Modified: 2015-11-21 19:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Vlookup Error (389.52 KB, image/jpeg)
2014-12-19 11:46 UTC, SriJanani
Details
Test 1 file (286.54 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-12-26 04:38 UTC, SriJanani
Details
test 2 file (185.42 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-12-26 04:38 UTC, SriJanani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SriJanani 2014-12-19 11:46:08 UTC
Created attachment 111038 [details]
Vlookup Error

Not sure if this is something related to interoperability of MS office/Libre office. In our organization as a leading manufacturing unit we deal with lot of supplier details and invoices. Started migrating to Libre office we do have lot of old data to be looked up for reference, however when we try to do a vlookup either using function wizard or manual formula it throws an error 504(to note )) getting added at the end). 

Upon multiple trys when we save that as a new file and do a vlookup it works for one time again it reacts the same. Going crazy to find out what could be the reason. I am attaching the files and the screen shot. Any help is appreciated.

Thank You,

Regards,
SriJanani
Comment 1 m.a.riosv 2014-12-20 00:54:56 UTC
Hello SriJanani,

Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 2 SriJanani 2014-12-26 04:38:12 UTC
Created attachment 111352 [details]
Test 1 file

Attached test file
Comment 3 SriJanani 2014-12-26 04:38:55 UTC
Created attachment 111353 [details]
test 2 file

Attached file refer U column
Comment 4 m.a.riosv 2014-12-26 13:30:34 UTC
I think the issue is with the single quote in the file name, because it is closing the first single quote getting a wrong formula.

try with:
'file:///c:/users/logistics/desktop/oct''14.ods'#topay.c2:j983
                                    -----------
escaping the single quote in the file name, and deleting unnecessary brackets at the end of the formula.

When possible the best is avoid special characters in file names, specially those that have special meaning in other areas.
Comment 5 SriJanani 2014-12-29 08:38:14 UTC
Thanks for the information, we will try and get back to you with updates...

Thank You,

Regards,
SriJanani
Comment 6 m.a.riosv 2015-08-23 22:43:54 UTC
Please @SriJanani, is the issue solved?
Comment 7 m.a.riosv 2015-11-21 19:57:02 UTC
Resolved, not new input from reporter in three months.