Bug 87593 - Check for updates propose 4.3.5 version
Summary: Check for updates propose 4.3.5 version
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.0.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-22 14:30 UTC by Laurent BP
Modified: 2015-01-15 09:17 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2014-12-22 14:30:51 UTC
Description: Fresh install of LibO 4.4.0 RC1 with "Check for updates automatically" indicates a new version is available, and propose to download LibO 4.3.5.

Steps to reproduce:
1. Select menu: Tools > Options > LibreOffice > Online Update
2. Click on "Check Now"

Observed behavior:
The UI says:
"LibreOffice 4.3.5 is available.
The installed version is LibreOffice 4.4.0.1."

Expected behavior:
LibO 4.4.0 should be considered as a superior version of LibO than LibO 4.3.5. So new version should be proposed.

Version: 4.4.0.1
Build ID: 1ba9640ddd424f1f535c75bf2b86703770b8cf6f
Locale: fr_FR
Comment 1 tommy27 2014-12-22 14:38:17 UTC
already reported in the QA mailing list as well. status NEW.
Comment 2 Thomas Hackert 2014-12-22 15:11:57 UTC
Hello Laurent, Tommy, *,
I can confirm it with 

LO Version: 4.4.0.1
Build ID: 1ba9640ddd424f1f535c75bf2b86703770b8cf6f
Locale: de_DE

(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel and with Germanophone help- as well as langpack) on Debian Testing i686 ... :( You can see it even faster, if you install 4.4.0.0RC1, start and close it, and start it again ... ;)
HTH and HAND
Thomas.
Comment 3 Robinson Tryon (qubit) 2014-12-22 15:31:14 UTC
I believe Cloph mentioned that he was addressing the updater. I'm cc'ing him for further details.
Comment 4 Peter Maunder 2014-12-23 17:07:56 UTC
I confirm I have the same problem, Linux-Mint Mate 17 with en-GB. I am running 4.3.4.1 and 4.4.0.1 both downloaded and installed directly using sudo dpkg -i *.deb. The two versions share the same ./config/LibreOffice/4

The update icon only shows with 4.4.0.1, it does not show when running 4.3.4.1.
Comment 5 Martin Srebotnjak 2014-12-29 20:03:28 UTC
I can confirm this bug on Windows XP SP3 4.4RC1, with Slovenian langpack.
Comment 6 Robinson Tryon (qubit) 2014-12-29 20:11:53 UTC
I think we're all set for repro results on this bug for now. Please focus your efforts on our UNCONFIRMED bugs:

https://bugs.freedesktop.org/buglist.cgi?bug_status=UNCONFIRMED&product=LibreOffice

Thanks!
Comment 7 Robinson Tryon (qubit) 2015-01-14 19:29:29 UTC
Update to 4.4.0.2 rc, and the problem is gone.

Status -> RESOLVED WORKSFORME
Comment 8 retired 2015-01-15 09:17:48 UTC
Verified, OSX 10.10.1 LO 4.4.0.2