Bug Hunting Session
Bug 87675 - "Edit" button near drop-down lists in paragraph style properties for selection of next style & linked Style
Summary: "Edit" button near drop-down lists in paragraph style properties for selectio...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium enhancement
Assignee: Heena Gupta
URL:
Whiteboard: target:5.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-24 09:07 UTC by Heena Gupta
Modified: 2015-04-09 10:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Missing Edit Button For Next Style in Edit Paragraph Style (54.46 KB, image/png)
2014-12-24 09:07 UTC, Heena Gupta
Details
Missing Edit Button For Next Style in Edit Paragraph Style (54.46 KB, image/png)
2014-12-24 09:10 UTC, Heena Gupta
Details
Screenshot of the Expected Behaviour (36.58 KB, image/png)
2014-12-29 06:44 UTC, Heena Gupta
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heena Gupta 2014-12-24 09:07:23 UTC
Created attachment 111263 [details]
Missing Edit Button For Next Style in Edit Paragraph Style

Steps:-

1) Open the Document in writer
2) Right Click on the document -> "Edit Paragraph Style"
3) Dialog appears
4) Click on Organizer button 
5) No "Edit" button for Next Style drop-down list to open selected style properties for editing

Expected Behaviour:- "Edit" button for Next Style drop-down list so that user can edit selected style
Comment 1 Heena Gupta 2014-12-24 09:10:47 UTC
Created attachment 111264 [details]
Missing Edit Button For Next Style in Edit Paragraph Style
Comment 2 Cor Nouws 2014-12-24 10:33:12 UTC
Hi Heena,

thanks for reporting the idea. I would say it's a bit superfluous since one can already edit that next style from the window Styles and formatting etc etc...

I set to UX-advice..
Cor
Comment 3 Heena Gupta 2014-12-29 06:44:23 UTC
Created attachment 111454 [details]
Screenshot of the Expected Behaviour
Comment 4 Muthu 2014-12-29 09:32:12 UTC
@Cor: Some how this seems to be listed in https://wiki.documentfoundation.org/Development/Really_basic_missing_features_and_enhancements

Hence the effort.

[Of course, it might be helpful to have edit buttons for all the styles...]
Comment 5 Muthu 2014-12-29 09:32:40 UTC
Link to Heena's patch: https://gerrit.libreoffice.org/#/c/13639/
Comment 6 Heena Gupta 2015-01-07 07:18:23 UTC
Link to patch for linked style:-
https://gerrit.libreoffice.org/#/c/13785/
Comment 7 Cor Nouws 2015-01-07 10:27:32 UTC
HI all,

(In reply to Muthu from comment #4)
> @Cor: Some how this seems to be listed in
> https://wiki.documentfoundation.org/Development/
> Really_basic_missing_features_and_enhancements
> 
> Hence the effort.

OK :) Indeed it makes life easier there.
 
> [Of course, it might be helpful to have edit buttons for all the styles...]

I'm a bit worried about editing the linked style from there too.
This means that not only the style from which dialog this starts will be affected, but potentially many others too. Are we sure that this do not expose users with limited knowledge to a avalanche of effects ;) ? Well, of course we can see...
Comment 8 Caolán McNamara 2015-01-07 15:10:28 UTC
I think if the "next style" is the same as the current style then you should disable the button. Otherwise you can modify the style in the dialog, e.g. indent, use "edit style" to edit the same style again in another dialog and modify it inconsistently with the still open parent dialog.
Comment 9 Heena Gupta 2015-01-08 08:48:20 UTC
Hi Caolan,

Thanks.
Working on it( if "next style" is same as the current style then disable the "Edit Style" button).
Comment 10 Heena Gupta 2015-01-09 05:53:47 UTC
Link to the patch(disable edit button when next style is same as current one):-
https://gerrit.libreoffice.org/#/c/13811/
Comment 11 Commit Notification 2015-02-06 23:58:10 UTC
Heena Gupta committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=de896f74c805e77706cce10f4d79117af1811ee9

fdo#87675-"Edit" Button for next style in edit paragraph style

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2015-02-06 23:58:18 UTC
Heena Gupta committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4be6e7becec9413cfd22c06376031b02486145b2

fdo#87675: Disable 'edit' when next style is same as current one.

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2015-04-09 09:31:04 UTC
Heena Gupta committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0242f4a41e40ab5a458b51657319b95ef19b05e1

Related: tdf#87675 "Edit" Button for linked style in edit paragraph style

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2015-04-09 09:34:22 UTC
Heena Gupta committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fecdbcab90c0373e0c172835f237d86baed6d1bb

Related: tdf#87675 Edit Linked Style Button is nonclickable on None Entry

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.