Bug Hunting Session
Bug 87687 - Merging cells does not move references in equations
Summary: Merging cells does not move references in equations
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Merge-Split Cell-Reference
  Show dependency treegraph
 
Reported: 2014-12-24 20:56 UTC by dazky
Modified: 2019-07-30 11:24 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
example merging cells (22.42 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-12-24 20:56 UTC, dazky
Details
Ssmple file (10.22 KB, application/vnd.oasis.opendocument.text)
2014-12-25 22:25 UTC, m.a.riosv
Details
sample with comment (24.68 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-01-01 12:00 UTC, dazky
Details
Simple Merge Example (12.15 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-04-19 05:54 UTC, mahfiaz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dazky 2014-12-24 20:56:35 UTC
Created attachment 111298 [details]
example merging cells

When I merged cells, some formula stopped working.
I send an example in attachment.


Similar as Bug 72121
Comment 1 m.a.riosv 2014-12-25 22:25:57 UTC
Created attachment 111337 [details]
Ssmple file

Please @dazky, what is stopping?
D18=sum(D14:D17)=0
cells in D14:D17 are empty.

When merging cells having values/formulas in cells to be hide a question about move the content of hidden cells to the first is showed, answering not hidden cells keep their values/formulas.

See in columns K+J in your modified sample file.
Comment 2 raal 2014-12-28 18:23:51 UTC
Setting as NEEDINFO, set to unconfirmed after answering the question from comment 1.
Comment 3 dazky 2015-01-01 11:54:33 UTC
Comment on attachment 111337 [details]
Ssmple file

I added an sample, if this is a bug, then I will come this behavior inappropriate and a possible source of error. MS Excel works a little differently ...
Comment 4 dazky 2015-01-01 12:00:02 UTC
Created attachment 111607 [details]
sample with comment

I added an sample, if this is a bug, then I will come this behavior inappropriate and a possible source of error. MS Excel works a little differently ...
Comment 5 Joel Madero 2015-10-16 03:32:04 UTC
Hi dazky - 

First let me apologize for the delay, QA team has been really busy and we missed some of these older reports.

That being said, I hate to say that I have to throw this back into NEEDINFO. The attachment is WAY to complicated. We need a VERY simple test case demonstrating the issue. This has way too many comments to follow and might even be showing different issues. Please attach a very very simple (it seems like 3 values would be enough to demonstrate whatever problem you're seeing) attachment and then set to unconfirmed. I will try to move it forward as soon as you do.

Also it would be nice if you check with 5.0.2.2 or later to verify the issue still exists.

Thanks for your patience and understanding.
Comment 6 mahfiaz 2016-04-19 05:54:51 UTC
Created attachment 124484 [details]
Simple Merge Example

To reproduce:

1. Type something in B1
2. Type =B1 in B2
3. Merge A1:B1
4. Notice that Calc does not move reference in B2 from =B1 to =A1 while Excel does.

See the attached Simple Merge Example document.
Comment 7 QA Administrators 2017-05-22 13:26:16 UTC Comment hidden (obsolete)
Comment 8 Xisco Faulí 2017-07-13 11:00:29 UTC
Setting Assignee back to default. Please assign it back to yourself if you're
still working on this issue
Comment 9 QA Administrators 2018-07-14 02:46:32 UTC Comment hidden (obsolete)
Comment 10 mahfiaz 2018-07-24 13:01:38 UTC
Still not working as expected in 6.0.3.2
Comment 11 QA Administrators 2019-07-30 03:13:50 UTC Comment hidden (obsolete)
Comment 12 mahfiaz 2019-07-30 11:24:18 UTC
Still not working in 6.2.4.2