Bug 87698 - open base report gives error
Summary: open base report gives error
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-25 09:59 UTC by cm20
Modified: 2014-12-28 08:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cm20 2014-12-25 09:59:52 UTC
linux opensuse thumbleweed
libreoffice base Version: 4.3.5.2.0+ Build ID: 430m0(Build:2)

creating a report

show report / open existing report: >> error:

"Can not activate the factory for org.libreoffice.report.pentaho.SOReportJobFactory$_SOReportJobFactory because java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory"

report can't be opened!

thanks
Comment 1 Robert Großkopf 2014-12-26 08:11:44 UTC
Have tested it with OpenSUSE 12.3 and OpenSUSE 13.2 on different systems. All works well with the original packages of LO 4.3.5.2 (www.libreoffice.org). Then I tested with the LO-version of OpenSUSE, as it seems to be reported for (The Bild-ID is a special format of OpenSUSE, the original of LO looks like 
Version: 4.3.5.2
Build-ID: 3a87456aaa6a95c63eea1c1b3201acedf0751bd5).

With LO-version of OpenSUSE I couldn't open a report, but won't get the same Java-error as reported. Could only test Version 4.3.3.2, original installed together with OpenSUSE 13.2.

Seems to be a special bug of the OpenSUSE-packages. So please report it to OpenSUSE, not to LO. How it has to be done:
https://en.opensuse.org/openSUSE:Submitting_bug_reports

You could also install the original version of LO. You could get it here: http://www.libreoffice.org/
Reports would be opened with this version. Bugs for this version you could report here.
Comment 2 Julien Nabet 2014-12-28 08:16:58 UTC
Following Robert's comment, I put this tracker to NOTOURBUG.