Bug Hunting Session
Bug 87747 (Picture_Embedding) - Add user pref to embed pictures (instead of linking) when copying-in web content
Summary: Add user pref to embed pictures (instead of linking) when copying-in web content
Status: RESOLVED DUPLICATE of bug 51609
Alias: Picture_Embedding
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-12-26 15:25 UTC by Peter Ludwig
Modified: 2016-02-09 10:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Ludwig 2014-12-26 15:25:36 UTC
Hi there,

I had mentioned this problem before and it had been changed in the last version (4.3.2 - yippieh) but it seems that there are many people out there who are not satisfied with the changed thing (or it is a bug) - thats why the changes were reverted in the newset version of writer? (all pictured copied from a webside are just linked - not embedded)

The problem:

If I paste a page/webside from the internet all pictures are just linked. So I have to click on Edit -> links "lösen" ... to embed these pictures. If I forget to do this all pics are lost and the document has no pics. :(( Thats not helpful.

However: Many people seem to like this. (I can understand this too)

My improvement:

Why not putting a setting / switch field / tick field in Preferences / Paths similar to:

"Embed all pictues inserted automatically" OR "Just link all pictures inserted"

Then even afterwards or before they create a document people coud decide if they would like to embed pictures or just link them and all people would be happy. 

How about that?

Hope this will be not too much a problem and thanks for your time and considerations.
Comment 1 Robinson Tryon (qubit) 2014-12-27 04:59:17 UTC
(In reply to Peter Ludwig from comment #0)
> My improvement:
> 
> Why not putting a setting / switch field / tick field in Preferences / Paths
> similar to:
> 
> "Embed all pictues inserted automatically" OR "Just link all pictures
> inserted"

Handing this to the UX Team

Status -> NEW
Comment 2 Yousuf Philips (jay) (retired) 2014-12-27 14:47:48 UTC
I believe that if content is being pasted into a document (.odt, .docx), then it should embed the pictures and if it pasted into an html document (.html) it should link the pictures. The last thing a user would want is pasting content into a document and the pictures are linked and then not being able to view the images when they are not online or the linked source is not accessible.
Comment 3 Peter Ludwig 2014-12-27 18:15:18 UTC
Thats my thinking too. But I read on other places in the internet that some people want to have pictures just linked to keep the document size small and that they can change the link to the pic later on. I can understand that too thats why I thought why not have both options and let people decide? It should not be too much a problem I hope. (But I am not a programmer ^^)

My idea was having a switch there: in "Tools -> Options -> Paths": 
O Link pictures 
X Embed pictures

I just checked the newest version:

4.3.5.2

The links have to be "broken" manually to have them embedded.
Comment 4 Yousuf Philips (jay) (retired) 2014-12-27 18:28:11 UTC
I think the simplest place to implement this is in the paste special dialog in the form of a checkbox. But i believe the default should be embed unless the user chooses otherwise, primarily because most users are not familiar with Edit > Links and by default we insert images as embed and not links.
Comment 5 Peter Ludwig 2014-12-27 18:54:05 UTC
I think thats a good idea too! The paste special place is where people might look first. I am completely with you! Embedding should be the default.
Comment 6 Cor Nouws 2014-12-27 20:56:12 UTC
I like the proposals.
Was thinking about paste special too, but that might be "more interesting" to implement ;)
Comment 7 steve -_- 2016-02-09 10:46:00 UTC
actually this is a dupe of #51609

hope this get's changed. linking images is really a bad idea. should be embedded. what if you don#t have internet? your entire document is f**ked.

*** This bug has been marked as a duplicate of bug 51609 ***