Bug 87756 - Saving embedded chart removes prompt to save spreadsheet
Summary: Saving embedded chart removes prompt to save spreadsheet
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2014-12-26 23:47 UTC by Todd
Modified: 2021-07-27 14:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Todd 2014-12-26 23:47:03 UTC
Hi All,

LibreOffice_4.3.5_Linux_x86-64_rpm.tar.gz

"Major" because I lost data discovering this bug.

Would one of our intrepid heroes please fix this for me?

The expected behavior is that if you attempt to exit a unsaved spreadsheet. LO will prompt you to save.  

If you have been editing a "Chart" from an unsaved spreadsheet and press on the "save" icon, you will save the chart you were working on.  

Unfortunately, LO will also think you saved spreadsheet's data and allow you to exit without saving spreadsheet's data.

To reproduce.

1) new spreadsheet.

2) enter 
     A    B
1    1    2
2    2    3
3    3    4

2) highlight A1..B3 and click on the chart easel icon. press finished

3) click inside the chart

4) (still inside the chart) click the "save" icon and save your new chart

5) (still inside the chart) click the "X" in LO's top upper right decoration.  You will not be prompted to save your spreadsheet's data.  Your data will be lost

Many thanks,
-T
Comment 1 Robinson Tryon (qubit) 2014-12-27 04:51:26 UTC
TESTING with LO 4.4.0.1 + Ubuntu 14.04

(In reply to Todd from comment #0)
> To reproduce.
> 
> 1) new spreadsheet.
> 
> 2) enter 
>      A    B
> 1    1    2
> 2    2    3
> 3    3    4
> 
> 2) highlight A1..B3 and click on the chart easel icon.

(It's a pie-chart icon in LO 4.4.0.1)

>  press finished
> 
> 3) click inside the chart
> 
> 4) (still inside the chart) click the "save" icon and save your new chart
> 
> 5) (still inside the chart) click the "X" in LO's top upper right
> decoration.  You will not be prompted to save your spreadsheet's data.  Your
> data will be lost

NOREPRO: If I click on the 'Chart Data Table' icon, my data is still there.

I think the repro steps should show that *other* data isn't saved.

Example: Add an additional cell to column B:

     A    B
1    1    2
2    2    3
3    3    4
4         5

Then, when we look at the information under the 'Chart Data Table' icon, the value '5' will not appear, and the data is lost.

Status -> NEW
Comment 2 QA Administrators 2016-01-17 20:02:19 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2017-03-06 13:52:14 UTC Comment hidden (obsolete)
Comment 4 eisa01 2019-11-03 15:36:28 UTC
I can not replicate this.

At step 4, LO saves the full spreadsheet as an ods file. Am I missing something?
There's no way to save only the chart?

Version: 6.4.0.0.alpha1+
Build ID: 80109586e6cb6d3e2e0a53a9079c3125ec9b8368
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 stragu 2021-07-27 14:17:11 UTC
Can't reproduce in:

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: cd2b5168e8ef1cb6e721bc5220421464ed723096
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-07-21_14:56:23
Calc: threaded

Or in:

Version: 7.0.6.2
Build ID: 144abb84a525d8e30c9dbbefa69cbbf2d8d4ae3b
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

Following the steps, the file is saved as an ODS, and no data is lost.
I can't use the Data Table feature, as in spreadsheets it seems Data Ranges is the enforced default.

As per my testing and Elsa's, Marking as WORKSFORME, but feel free to test and reopen if I am missing something...