Bug Hunting Session
Bug 87831 - Icon on Windows taskbar becomes obsolete when new version is installed
Summary: Icon on Windows taskbar becomes obsolete when new version is installed
Status: RESOLVED DUPLICATE of bug 76131
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.2 all versions
Hardware: x86 (IA32) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: needsWindows
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-29 15:00 UTC by Richard Marchessault
Modified: 2017-07-29 13:29 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Marchessault 2014-12-29 15:00:45 UTC
Problem description: 
I have a start up icon for LibreOffice on my task bar. When a new version is installed this icon becomes non-functional and must be deleted and a new one created to replace it which points to the newly installed version.

Steps to reproduce:
1. .... Install a new version
2. .... Icon on task bar for old version cannot be used for new version
3. ....

Current behavior:
Old icon on the Windows taskbar becomes obsolete on installation of a new version.

Expected behavior:
Icon on the task bar used for the previous version can work with the new version after installation.
Comment 1 Yousuf Philips (jay) (retired) 2014-12-29 18:38:55 UTC
Is the new version like 4.2.6 to 4.2.7 or 4.2 to 4.3?
Comment 2 Richard Marchessault 2014-12-29 22:11:35 UTC
I just upgraded to version 4.2.8.2 and the problem exists with this version as it has for all previous versions.
Comment 3 tommy27 2015-02-15 10:08:28 UTC
@Richard
please retest installing 4.3.5 over 4.2.8 and tell if issue persists.
Comment 4 Buovjaga 2015-02-22 13:18:24 UTC
Yep, retest would be nice.. even with 4.4 / 4.4.1.
Also, what Windows version are you using? 7, 8, 10?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 5 QA Administrators 2015-09-04 02:56:16 UTC Comment hidden (obsolete)
Comment 6 Richard Marchessault 2015-09-04 12:30:07 UTC
I am using the latest version 4.4 and the bug is still a problem. Hope you can fix it with the next release.
Comment 7 tommy27 2015-09-04 13:59:35 UTC
well, the latest version is 5.0.1
please retest and answer all the questions from comment 4 about your O/S

back to NEEDINFO
Comment 8 Richard Marchessault 2015-09-04 16:44:46 UTC
Just installed version 5.0.1.2 on my Windows 7 system. Problem has not been fixed. Icons on task bar do not point to the newly installed LibreOffice components. Have to remove icons and manually add them back.
Comment 9 sstory 2016-04-19 17:27:10 UTC
I just installed LibreOffice 5.1.2 on Windows 7 64bit. I had a desktop shortcut to Calc, the properties being: "C:\Program Files (x86)\LibreOffice 4\program\scalc.exe"

The result confirms that these shortcuts get broken. I think that if this user is making shortcuts to individual applications like Calc and Writer like I do, that this is a problem. I the past it was installed to something like LibreOffice 3.x.y which meant this was a problem with every release. Sometime during 4.x, it was changed to be LibreOffice 4 which meant that all upgrades within a major version should not break these shortcuts. However, major version upgrades like 4 to 5, will obviously break them because this:


"C:\Program Files (x86)\LibreOffice 4\program\scalc.exe"

becomes:

C:\Program Files (x86)\LibreOffice 5\program\scalc.exe"

With the 4 changing to a 5. I believe the problem would be forever eliminated by just installing to LibreOffice without any version numbers each time--unless there is a really good reason why this isn't possible or desirable.

Now if the user is referring to the startup icon installed by LibreOffice, that is a totally different story.
Comment 10 sstory 2016-04-19 21:24:00 UTC
I installed 5.1.2.2 on another Windows 7 64bit machine from version 4.4.  The main LibreOffice icon of 4.x was removed and since I checked the checkbox on install the 5.1.2.2 LibreOffice icon appeared back on the desktop. However, as mentioned above, if the OP was making shortcuts to individual apps, like Calc, Writer (like I do), those do break. I like to make those because it is more convenient for me and 90% of the time I am using Calc or Writer.  If I need the other apps, I don't mind digging more for them.
Comment 11 sstory 2016-04-19 21:27:15 UTC
I believe he is referring to shortcuts to individual apps.  In that case he is correct.  I reopened so someone would consider the possibility of installing to just \LibreOffice with no version number to avoid ever breaking these type shortcuts--which I believe now only break between major versions.
Comment 12 V Stuart Foote 2016-04-19 23:55:50 UTC
How is this a LibreOffice deployment issue?  The OP and all discussion since are talking about shortcuts set outside the LO package installation. That they break is outside control of LibreOffice that is self inflicted by users. When the path changes the shortcuts break--end of story.

The next major milestone where this again occurs will be the 6.x, or for folks upgrading from 4.x to a 5.x release.

LibreOffice support for Windows Jump list behavior for "pin-to" the Start Menu and the Task bar.  That continues to function correctly--so, setting per application shortcuts is kind of a user inflicted pain.

As a corollary to this we have the user profile that we specifically did not change at %APPDATA%\LibreOffice\4 so user profiles would transition major releases based on ESC decision.  Personally I think that was wrong--but the project was taking care of its own internals in that case.

Over to Resolved Wont Fix
Comment 13 sstory 2016-04-20 12:36:02 UTC
V Stuart Foote,

I had merely reopened so that someone above would take a look at the problem as it seemed from past replies that no one was understanding that he seemed to be making shortcuts to individual apps. I was also pointing out the fix.  As an admin of several users, I also make shortcuts on each of their desktops to Calc and Writer and must recreate those every major release--not as big of a pain as when the entire version number was on the folder.

If the consensus is to not fix it then I guess that is that, but if there is not some need for the version number, doing away with it on the directory would have made things nicer for the OP, myself and perhaps many other admins.

Thanks
Comment 14 V Stuart Foote 2016-04-20 14:55:32 UTC
Enhancement of bug 62303 is still open to make the default installation directory just LibreOffice. When and if that rolls, this will resolve.

By ESC decision, 4.y.z and 5.y.z releases have installed to the "\LibreOffice [4|5]" directory.
Comment 15 sstory 2016-04-20 16:06:26 UTC
V Stuart Foote :

Thanks for the clarification and enhancement "bug" link. I added my own comment to it as another reason why it would be nice on Windows boxes to do it that way.

Thanks again.
Comment 16 Kumāra 2016-12-09 10:06:18 UTC
(In reply to sstory from comment #9)
> Sometime during 4.x, it was changed to be LibreOffice 4 which meant that all
> upgrades within a major version should not break these shortcuts. However,
> major version upgrades like 4 to 5, will obviously break them because this:
> 
> 
> "C:\Program Files (x86)\LibreOffice 4\program\scalc.exe"
> 
> becomes:
> 
> C:\Program Files (x86)\LibreOffice 5\program\scalc.exe"
> 
> With the 4 changing to a 5. I believe the problem would be forever
> eliminated by just installing to LibreOffice without any version numbers
> each time--unless there is a really good reason why this isn't possible or
> desirable.

Are you sure this is the case? In my experience, it happens upon *every* upgrade.
Comment 17 Kumāra 2016-12-09 10:11:55 UTC
I believe Comment 1 by rj_libreoffice@ObjectMail.com over there is correct:

"I suspect that the reason for this is because the MSI installer first uninstalls the old version, which includes removing LibreOffice shortcuts. Somehow this must mess up the shortcut on the taskbar."

If the MSI is set NOT to remove the existing LO shortcuts, the problem may be solved. Hope the people working on the installer can look into this.

*** This bug has been marked as a duplicate of bug 76131 ***