Bug 87948 - EDITING: Involuntary copy and paste when selecting multiple form controls
Summary: EDITING: Involuntary copy and paste when selecting multiple form controls
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-01 19:25 UTC by James B. Byrne
Modified: 2015-10-11 14:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
OBD with simple form that exhibited the same problem (11.82 KB, application/vnd.sun.xml.base)
2015-01-07 21:12 UTC, James B. Byrne
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James B. Byrne 2015-01-01 19:25:44 UTC
When attempting to additionally select multiple text boxes using cmd+shift to select only the control from controls grouped with labels frequently the selection is interrupted by an involuntary copy and paste or cut and paste of the previously selected controls.

For example, given three label/control groups: 

lbl-1+ctl-1  lnl-2+ctl-2  lbl-3+ctl-3

When I use shift+command+left mouse-click in an attempt to add ctl-3 to a selection that already includes ctl-1 and ctl-2 I sometimes have both ctl-1 and ctl-2 moved or copied to a form location on or below ctl-3.

lbl-1+ctl-1  lnl-2+ctl-2  lbl-3+ctl-3
                        ctl-1        ctl-2

This occurs whether the onboard trackpad is enabled or disabled or whether the mouse is wired or wireless.
Comment 1 Alex Thurgood 2015-01-03 16:02:06 UTC
Please provide exact step by step instructions to reproduce this behaviour and preferably a sample ODB document containing a form which exhibits the behaviour. Personally, this is not something I've seen so far in the Mac version of LO.

Setting to NEEDINFO. When you have supplied the requested information / file, please set back to UNCONFIRMED
Comment 2 Alex Thurgood 2015-01-03 17:38:24 UTC
Adding self to CC if not already on
Comment 3 James B. Byrne 2015-01-07 21:12:36 UTC
Created attachment 111931 [details]
OBD with simple form that exhibited the same problem
Comment 4 James B. Byrne 2015-01-07 21:21:52 UTC
Steps to reproduce:

1. create a simple database with one table.

2. create a form from that table.

3. open the form in design view.

4. rearrange controls on the form in groups selected with the shift key and left-mouse button.

5. at some point whilst moving a selected group of controls they either will be cut and pasted to an arbitrary location close to or on the mouse path, duplicated, or deleted.  


I am unable to reproduce this problem on a Linux host.  However, I encounter it with some frequency on a Macbook Pro.  The enclosed odb file exhibited the problem once, at which point I save the work.

I note that on the this occasion the selected controls actually disappeared, as if they had been deleted.  On the edit menu the redo option read:

Undo: Move "   (this might be '' instead of " I could not tell)
Comment 5 Alex Thurgood 2015-01-12 11:25:33 UTC
Can not reproduce on LO 4352 with OSX 10.10.1

From the test file, I opened the form in form design mode, pressed the shift key and left mouse button clicked on the fields Comapny Name, Department and Notes. The grouped selection could be moved around with the mouse anywhere in the form, the controls never disappeared. If I deselected the grouped selection, I could select any other group of controls, or the same ones, and repeat the procedure without loss or disappearance of the controls.

You don't mention which version of OSX you are using. Please provide that information. If, as for another bug report I've seen you've filed, you are on OSX 10.4, then you are using a 32bit version of LO which is no longer officially supported for use on OSX 10.4 and this will be marked as wontfix.

Setting to NEEDINFO
Comment 6 Julien Nabet 2015-10-11 14:08:08 UTC
No feedback since 9 months, let's put this to WFM.

James: don't hesitate to reopen this tracker if you can still reproduce this with recent LO version (last one is 5.0.2) + after having provided asked information comment 5.