Bug 87975 - CRASH when adding mac address data source
Summary: CRASH when adding mac address data source
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2015-01-02 17:03 UTC by Rand Bamberg
Modified: 2017-08-01 10:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Mac OS stack trace (70.68 KB, text/plain)
2015-01-02 17:03 UTC, Rand Bamberg
Details
New stack trace with fresh user profile, 4.4.0RC1 (81.27 KB, text/plain)
2015-01-03 02:00 UTC, Rand Bamberg
Details
backtrace of same crash, same steps, with latest version 4.4.2 (81.66 KB, text/plain)
2015-04-11 15:30 UTC, Rand Bamberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rand Bamberg 2015-01-02 17:03:47 UTC
Created attachment 111661 [details]
Mac OS stack trace

Steps to reproduce:

Open LibreOffice (latest released version for Mac)
Choose File --> Wizards --> Address Data Source
Choose "Mac OS X address book" radio button
Click "Next"
[CRASH]

Stack trace (taken from the "LibreOffice has quit unexpectedly" crash dialog) is attached...
Comment 1 Julien Nabet 2015-01-02 21:14:29 UTC
On MacOs 10.9.5 with LO 4.3.5, I don't reproduce the crash.
1) on which MacOs version are you? (4.3.5 need 10.6 minimum and 10.8 min for x86-64, see http://www.libreoffice.org/download/libreoffice-fresh/#change)
2) for the test, could you rename you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Mac_OS_X) and give it a new try?
Comment 2 Rand Bamberg 2015-01-03 02:00:34 UTC
Created attachment 111678 [details]
New stack trace with fresh user profile, 4.4.0RC1
Comment 3 Rand Bamberg 2015-01-03 02:03:03 UTC
(In reply to Julien Nabet from comment #1)
> On MacOs 10.9.5 with LO 4.3.5, I don't reproduce the crash.
> 1) on which MacOs version are you? (4.3.5 need 10.6 minimum and 10.8 min for
> x86-64, see http://www.libreoffice.org/download/libreoffice-fresh/#change)
> 2) for the test, could you rename you rename your LO directory profile (see
> https://wiki.documentfoundation.org/UserProfile#Mac_OS_X) and give it a new
> try?

Hi Julien, thanks for looking...
1) This is with MacOS 10.10.1 (Yosemite)
2) I tried resetting the profile (renamed it to user-old) and then retried same set of steps: same result (crash).

I also downloaded and installed 4.4.0RC1, then retried: same result (crash). I uploaded a fresh stack trace from this attempt since it was a new build.
Comment 4 Julien Nabet 2015-01-03 10:08:49 UTC
Thank you Rand for your feedback.
(putting at NEW since there's a bt)

Alex: do you reproduce this too?
Comment 5 Alex Thurgood 2015-01-03 15:56:11 UTC
This has happened in the past, but haven't tried it recently, will give it a go
Comment 6 Alex Thurgood 2015-01-03 17:41:16 UTC Comment hidden (no-value)
Comment 7 Rand Bamberg 2015-04-11 15:30:56 UTC
Created attachment 114740 [details]
backtrace of same crash, same steps, with latest version 4.4.2

Just trying this periodically with new releases of LO; no change.  Regards -R
Comment 8 tommy27 2016-04-16 07:28:38 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2017-05-22 13:26:48 UTC Comment hidden (obsolete)
Comment 10 Julien Nabet 2017-07-29 22:55:45 UTC
On MacOS 10.12 with master sources updated some days ago, I don't reproduce this.

Any better with recent version?
I took a look to initialize indicated in the bt (see https://opengrok.libreoffice.org/xref/core/connectivity/source/drivers/macab/MacabRecords.cxx#139)
the only call to CFArrayGetCount in this function is here:
recordsSize = (sal_Int32) CFArrayGetCount(allRecords);

(see https://opengrok.libreoffice.org/xref/core/connectivity/source/drivers/macab/MacabRecords.cxx#171)
and allRecords is initialized just some lines before.

Just wonder too if it could be linked to the number of contacts, how many contacts have you got?
Comment 11 Alex Thurgood 2017-08-01 10:35:33 UTC
WFM with

Version: 5.3.4.2
Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3
Threads CPU : 8; Version de l'OS :Mac OS X 10.12.6; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group