Bug Hunting Session
Bug 87987 - Changing text scale in writer is broken
Summary: Changing text scale in writer is broken
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.7.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-03 06:27 UTC by Roman Elshin
Modified: 2016-05-09 20:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
"qwerty123" test string with 160% scale for example (42.83 KB, image/png)
2015-01-03 06:27 UTC, Roman Elshin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Elshin 2015-01-03 06:27:46 UTC
Created attachment 111680 [details]
"qwerty123" test string with 160% scale for example

Changing text scale in writer is broken if user prefer non anti aliased fonts in system, some characters are replaced by empty spaces if custom scale factor are selected, linux x86, ver: 4.2.7.2, build ID: 420m0(Build:2).
Comment 1 tommy27 2015-01-03 17:10:08 UTC
upgrade to 4.3.5.2 and see if issue persists.
Comment 2 Roman Elshin 2015-01-03 20:13:17 UTC
it also persist in 4.3.5.2.
Comment 3 Roman Elshin 2015-01-11 12:29:37 UTC
I can not reproduce issue with nouveau nor nvidia proprietary drivers, but it exists on systems with radeon graphics (at least with rv730 and turks).
Need to reassign this bug for xorg/xf86-video-ati?
Comment 4 Buovjaga 2015-01-16 12:16:53 UTC
Yeah, I'm unable to repro with
Ubuntu 14.10 64-bit 
Version: 4.3.3.2
Build ID: 430m0(Build:2)

..but I'm using a virtual machine :)

Roman: maybe you can find some Ubuntu users with Radeon cards to test?
Comment 5 raal 2015-03-14 20:57:06 UTC
I can not confirm with Version: 4.4.3.0.0+
Build ID: 8106e522c4ea2ae4441ec571579a38eeb6d9af04
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-4, Time: 2015-03-13_12:39:32
Intel graphic card.

To be certain the reported issue is not related to corruption in the user profile, could you rename this LibreOffice user directory ( see https://wiki.documentfoundation.org/UserProfile#Default_location or http://ask.libreoffice.org/en/question/903/where-are-the-libreoffice-data-profile-files/ ) and re-test?
Comment 6 tommy27 2015-05-24 15:51:10 UTC
@Roman Elshin
please answer raal's question.
also consider upgrading to LibO 4.3.7 or 4.4.3

set status to NEEDINFO waiting for feedback
Comment 7 QA Administrators 2015-12-27 20:31:15 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 8 QA Administrators 2016-05-09 20:07:52 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

This INVALID Message was generated on: 2016-05-09