Download it now!
Bug 88025 - XY (scatter) first column of Y data lost on editions
Summary: XY (scatter) first column of Y data lost on editions
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-04 20:50 UTC by andis.lazdins
Modified: 2018-03-07 06:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file of problematic chart (70.48 KB, application/vnd.oasis.opendocument.text)
2015-01-04 20:50 UTC, andis.lazdins
Details
looks identical (37.81 KB, application/vnd.oasis.opendocument.text)
2015-01-05 12:09 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andis.lazdins 2015-01-04 20:50:03 UTC
Created attachment 111735 [details]
Sample file of problematic chart

Rather complicated to describe the issue. 
I got text file from student with lot of line charts with Power regression equations, which supposed to be XY (scatter) charts with Exponential regression equations. When I start to edit charts (convert to XY scatter, setting certain scale of X bar and exponential trend line), I found that every time on reopen file all changed charts lost first Y column and column label.
It is not enough just to convert chart to XY to repeat this behaviour, but also trend line should be changed from power to exponential.

Steps to reproduce:
1. open attached file
2. select first chart and copy it
3. create new text file and paste chart there
4. change chart type to XY, change trend lines from power to exponential
5. set X axis scale from 0 to 40
6. save and close new file
7. reopen new file

The result for me is always like second chart in attached file. I don't know if it is necessary to repeat all steps from 4. to 5., because sometimes first Y column get lost on one of these steps.

The sample chart is originally created in Calc.

Ubuntu 14.04 32 bit, Libreoffice 4.3.5.2
Comment 1 andis.lazdins 2015-01-04 21:05:42 UTC
It looks like the reason is setting of original chart type in Calc as line. I don't know logical reasons behind (why to make line chart if XY is necessary), why to do so, but changing from line to XY seems to be making lost of data. 

It's impossible to make idiots proof solutions, but probably somehow this problem can be solved so that data are not lost, if somebody by mistake selected line chart instead of XY.
Comment 2 raal 2015-01-05 12:09:24 UTC
Created attachment 111765 [details]
looks identical

I can not confirm with LO 4.3.5, win7. Chart in new file looks identical.
Comment 3 raal 2015-01-05 12:12:56 UTC
I can confirm with LO 4.3.5, win7. After second open I see the same result as reporter. Setting as new.
Comment 4 QA Administrators 2016-01-17 20:03:45 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-03-06 14:14:36 UTC Comment hidden (obsolete)
Comment 6 andis.lazdins 2017-03-06 14:27:10 UTC
Looks fine in 5.2.6.1, Ubuntu 16.04 64 bit. Can be closed I guess.
Comment 7 QA Administrators 2018-03-07 03:41:20 UTC Comment hidden (obsolete)
Comment 8 andis.lazdins 2018-03-07 05:37:40 UTC
The problem is not appearing in 6.0.2.1, report can be closed as solved.
Comment 9 raal 2018-03-07 06:04:06 UTC
Closing