Bug 88048 - this svg image does not export correctly in pdf
Summary: this svg image does not export correctly in pdf
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: noRepo:4.4.0 noRepo:4.5.0alpha+
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-05 11:28 UTC by Frederic Parrenin
Modified: 2015-02-03 20:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
.odt file to reproduce the problem (153.74 KB, application/vnd.oasis.opendocument.text)
2015-01-05 11:28 UTC, Frederic Parrenin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2015-01-05 11:28:55 UTC
Created attachment 111761 [details]
.odt file to reproduce the problem

Steps to reproduce:
- open the attached .odt file
- export to pdf
- open the pdf
=> the X-axis title of the figure is not correct. It appears as "tim    yr B"
Comment 1 Adolfo Jayme Barrientos 2015-01-05 17:16:28 UTC
I could not reproduce this bug in my system (LibreOffice 4.5 [master build], Ubuntu 14.10, Evince 3.14.1). The exported PDF, generated from your attachment, displays correctly. Please try opening the PDF with another viewer or try updating to LibreOffice 4.4 RC1 and let us know if that helps. Thanks in advance.
Comment 2 Martin 2015-01-05 23:46:16 UTC
I can reproduce the bug on my system (LO 4.3.5.2, Linux Mint 13 Maya). The x-axis label is "tim R b"
Comment 3 Martin 2015-01-05 23:49:55 UTC
Further to Comment 2, the label is actually "tim    r B", sorry got the caps wrong in the previous post. Checked in both acroread 9.5.5 and evince 3.4.0.
Comment 4 DeepFlight5 2015-02-02 15:05:49 UTC
I can reproduce the bug on my system (LO 4.3.5.2, MacOSX 10.9). The x-axis label is "tim r B" instead of "time (kyr BP)". In Apple's Preview PDF viewer and in Adobe Reader 9.4.1.
Comment 5 V Stuart Foote 2015-02-02 17:31:19 UTC
Confirming malformed text in PDF export of SVG image
On Windows 7 sp1, 64-bit en-US with
Version: 4.3.6.2
Build ID: d50a87b2e514536ed401c18000dad4660b6a169e
And is also malformed on 4.3.6 with gs print to PDF.

However, it is correctly being exported to PDF, or with gs print to PDF in
Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: en_US

@Frederic please check a build of 4.4.0 or master (in parallel if you prefer) to see if this is resolved.

Leaving as NEEDINFO for now.
Comment 6 Frederic Parrenin 2015-02-03 19:21:07 UTC
This bug does not appear for me on 4.4 on Fedora 21.