Bug Hunting Session
Bug 88140 - Writer fails to open big file with lots of formulas
Summary: Writer fails to open big file with lots of formulas
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-07 08:12 UTC by Yury
Modified: 2015-10-15 09:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yury 2015-01-07 08:12:43 UTC
I'm working on a big document with lots of formulas in 3.6.7.2 (linux/amd64). 

Today writer began to crash on opening the document. It shows the line of squares in the statusbar, progress comes to about 65-70% then everything in writer stops (including the window redraws), `top` tool shows 101% cpu usage and about 40% mem usage for a couple of minutes, and finally writer crashes with the following output in the console:

terminate called after throwing an instance of 'std::bad_alloc'
  what():  std::bad_alloc

What do I do and am I ultimately screwed??

I can't migrate to 4.* series because of https://bugs.freedesktop.org/show_bug.cgi?id=88139 (I can open the doc there -- yet)

I can't attach the doc in question, as that is unpublished etc. The doc itself is ~4M in size, its zip structure is uncorrupted.
Comment 1 Buovjaga 2015-01-13 17:12:21 UTC
Can you do a regex to replace all characters with x or use this macro: https://wiki.documentfoundation.org/QA/BugReport/Attachments#Confidential_Attachments
Comment 2 Yury 2015-01-15 05:46:24 UTC
I've replaced the text letters, but will have to do the same with formulas. I'll have to modify the python script which I use for batch formula font settings modifications. Or you could suggest something of the kind which is ready-to-use. :)
Comment 3 raal 2015-03-14 20:59:57 UTC
Hello,

Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 4 Philipp Weissenbacher 2015-03-19 21:40:50 UTC
Hi,

Why are you using such an old version? The latest release is 4.4.1
Please download that and test your document there.
Comment 5 Yury 2015-03-20 04:43:43 UTC
(In reply to Philipp Weissenbacher from comment #4)
> Hi,
> 
> Why are you using such an old version? The latest release is 4.4.1
> Please download that and test your document there.

I need functionality and stability, not new numbers in version field. If 3.* series did its job, I wouldn't bother to upgrade. Especially when I'm working on the big document.

However, 3.6.7.2 stopped opening, and 4.4.2 can't save this doc (#88314). Happily, 4.3.* series can both open and save this (yet), with a penalty of having to re-render all formulas (opening them manually), twice (#88139, #88320).
Comment 6 Yury 2015-03-20 04:44:50 UTC
(In reply to raal from comment #3)
> Hello,
> 
> Thank you for reporting the bug. Please attach a sample document, as this
> makes it easier for us to verify the bug. 

Yes, of course, right after I obfuscate the formulas.
Comment 7 QA Administrators 2015-10-14 19:50:25 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-10-14
Comment 8 Yury 2015-10-15 09:38:03 UTC
I can't use the 3.* series because of that issue, so can't add anything new.

The big (obfuscated) file which couldn't be opened is at
 
https://bugs.documentfoundation.org/attachment.cgi?id=114621
Comment 9 Buovjaga 2015-10-15 09:55:09 UTC
(In reply to Yury from comment #8)
> I can't use the 3.* series because of that issue, so can't add anything new.
> 
> The big (obfuscated) file which couldn't be opened is at
>  
> https://bugs.documentfoundation.org/attachment.cgi?id=114621

I could open it just fine.

I think this could be closed as worksforme.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)