Bug Hunting Session
Bug 88184 - CRASH after undo a moved commented cell and pressing Del
Summary: CRASH after undo a moved commented cell and pressing Del
Status: RESOLVED DUPLICATE of bug 83192
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-01-08 00:20 UTC by MM
Modified: 2015-04-03 14:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MM 2015-01-08 00:20:01 UTC
Looks a bit like this bug, but not quite: https://bugs.freedesktop.org/show_bug.cgi?id=83192

Steps to reproduce:

- Add a comment to A1.
- Drag and drop A1 to A2.
- Undo (CTRL-Z)
- Press 'Delete'

Crash....

Tested on v4.3.5.2 on windows 7 and on mint 17.1 x64 and v4.1.6.2 on mint 16 x64.
Comment 1 raal 2015-01-08 10:38:10 UTC
I can confirm with LO 4.3.5, win7
Comment 2 Matthew Francis 2015-03-31 08:37:03 UTC
Tracks back to the same commit as bug 83192, so a duplicate

*** This bug has been marked as a duplicate of bug 83192 ***
Comment 3 MM 2015-04-03 14:19:44 UTC
(In reply to Matthew Francis from comment #2)
> Tracks back to the same commit as bug 83192, so a duplicate
> 
> *** This bug has been marked as a duplicate of bug 83192 ***

Well my bugreport is about a crash when pressing 'delete' or RMB -> 'Clear formatting' (after undo), the other one is about a crash when doing undo/redo a few times. Hope you're right that this is the same bug, else re-open.