Bug 88245 - A specific font in an RTF file causes an endless loop
Summary: A specific font in an RTF file causes an endless loop
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.2 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: needsWindows
Keywords: filter:rtf
Depends on: 88214
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-09 17:25 UTC by Urmas
Modified: 2016-05-09 10:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2015-01-09 17:25:52 UTC
+++ This bug was initially created as a clone of Bug #88214 +++

The attachment 111980 [details] causes the endless loop immediately after opening, seems to be depending on the font used.
Comment 1 Joel Madero 2015-01-10 03:11:18 UTC
Ubuntu 14.04 x64
LibreOffice 4.5 master
Build Date:   Fri Jan 2 21:30:03 2015 +0100

Perhaps Windows only. 

Urmas - does this affect 4.4 at all?
Comment 2 Urmas 2015-01-10 05:54:40 UTC
Yes, it is in 4.4.0.2 too.
Comment 3 Buovjaga 2015-01-15 20:09:46 UTC
No repro with 4.5 alpha, but it loops with 4.4 RC2.
I left it for a while and when I came back, there was a red spellcheck line going to the right all the way across, beyond the page border. Scrolled a bit, went to loop again.
I don't have any spellcheck in 4.5.

Win 7 64-bit Version: 4.4.0.2
Build ID: a3603970151a6ae2596acd62b70112f4d376b99

and Version: 4.5.0.0.alpha0+
Build ID: b3b4bbaf6cbd2226b659fea7d6ae473ccf84e9dd
TinderBox: Win-x86@39, Branch:master, Time: 2015-01-12_06:13:44
Comment 4 Robinson Tryon (qubit) 2015-12-14 11:28:00 UTC
Migrating Whiteboard tags to Keywords: ( filter:rtf)
[NinjaEdit]
Comment 5 Miklos Vajna 2016-05-06 16:41:07 UTC
Can you confirm it with 5.1 or newer? Otherwise I would suggest to close this.
Comment 6 Joel Madero 2016-05-06 16:49:48 UTC
Given that Buovjaga already said it's working in 4.5 but was broken in 4.4, I'm going to just close it as WFM.

@Urmas - if confirmed on 5.1 just set it back to NEW and leave a comment. Thanks
Comment 7 Buovjaga 2016-05-09 10:30:37 UTC
Yep, it doesn't loop for me in 5.1.2 with spellcheck.

Win 7 Pro 64-bit, Version: 5.1.2.2 (x64)
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)