Bug 88289 - Focus Template not displayed correctly on OS X
Summary: Focus Template not displayed correctly on OS X
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.0.2 rc
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: ToBeReviewed
Keywords: difficultyBeginner, easyHack, skillDesign
: 92202 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-11 10:53 UTC by retired
Modified: 2017-02-14 08:57 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
OSX 10.10.1 LO 4.4rc2 focus template not displayed correctly (141.63 KB, image/jpeg)
2015-01-11 10:53 UTC, retired
Details
template reduced to first slide only.odp (20.59 KB, application/vnd.oasis.opendocument.presentation)
2015-01-16 14:54 UTC, retired
Details
EMF+ metafile that is inside the template. (1.20 KB, image/x-svm)
2015-01-16 15:25 UTC, Jan Holesovsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description retired 2015-01-11 10:53:00 UTC
Created attachment 112088 [details]
OSX 10.10.1 LO 4.4rc2 focus template not displayed correctly

The new templates open fine except Templates > Presentations > Focus

Currently: the colors / background are not shown

Expected: Should display correctly.


Talked to Kendy about this, he said it was working fine on Linux + Windows, but on OSX the above issue is happening. Kendy said this qualified as a blocker.

Tested with:

LO 4.4RC2
LO 4.5 latest nightly 2015-01-09
Comment 1 Robinson Tryon (qubit) 2015-01-11 11:52:59 UTC
TESTING with LO 4.4.0.2 + Ubuntu 14.04

(In reply to foss from comment #0)
> The new templates open fine except Templates > Presentations > Focus
> 
> Currently: the colors / background are not shown
> ... 
> Talked to Kendy about this, he said it was working fine on Linux + Windows,

Yes -- I can't repro with LO running on Ubuntu.
Comment 2 Matthew Francis 2015-01-11 11:56:05 UTC
Confirmed on OSX 10.10.1 / LO 4.4.0.2
Background isn't shown
Comment 3 retired 2015-01-11 11:58:32 UTC
Plattform > All
since reproduced on Ubuntu
Comment 4 retired 2015-01-11 12:02:09 UTC
what a difference can and can't can make. sorry! back to OSX only
Comment 5 retired 2015-01-16 14:34:28 UTC
LO 4.3.5: imported focus.otp from LO 4.4
also shown as broken with missing colors etc
Comment 6 retired 2015-01-16 14:42:05 UTC
4.2.8.2 same issue.
Comment 7 retired 2015-01-16 14:54:37 UTC
Created attachment 112350 [details]
template reduced to first slide only.odp
Comment 8 Jan Holesovsky 2015-01-16 15:25:03 UTC
Created attachment 112352 [details]
EMF+ metafile that is inside the template.

Apparently it is a problem with reading EMF+ on OSX; this is the file inside the presentation.
Comment 9 retired 2015-01-16 15:36:52 UTC
update:

EMF+ metafile that is inside the template does show correctly on Win 8.1

On osx 10.10.1
4.4.0.2: nothing (empty white sheet)
4.5 2015-01-15 nothing
bonus track: NeoOffice: same.
Comment 10 Matthew Francis 2015-01-23 11:58:05 UTC
Confirmed by checking past releases that this has never displayed on OSX. Not sure if this is strictly an inherited bug or effectively a new feature that doesn't fully work yet.

For reference, though it may not be relevant, the first time this worked on Linux was after the below commit:

commit be7d87bea2611eb316b9b379aebc031179d4f794
Author: Andrzej J.R. Hunt <andrzej.hunt@collabora.com>
Date:   Thu Dec 5 11:36:53 2013 +0000

    EMF+: force canvas if EMF+ comments are used.
    
    Without this the drawinglayer renderer is used, whereas
    only the canvas renderer supports EMF+.
    
    Change-Id: Id8a10e400e08c1913e7d6864a51f7b73fc9be437
Comment 11 Adolfo Jayme 2015-06-20 15:33:03 UTC
*** Bug 92202 has been marked as a duplicate of this bug. ***
Comment 12 Andras Timar 2015-08-26 17:23:30 UTC
Fixing EMF+ rendering under OS X is difficult. I suggest a different approach. Use SVG images instead of EMF+/SVM images as slide background.
Comment 13 steve -_- 2015-08-26 17:41:39 UTC
def not "blocker", setting to "normal". Would be great to get this fixed anyhow. Since there's a stronger emphasis on templates, the few default templates should be working on all OSs.
Comment 14 Robinson Tryon (qubit) 2015-12-14 06:37:39 UTC Comment hidden (obsolete)
Comment 15 Samuel Mehrbrodt (CIB) 2015-12-15 08:52:01 UTC
No code pointers -> no easy hack
Comment 16 Andras Timar 2015-12-15 09:43:53 UTC
My suggestion was to use SVG images as slide backgrounds in extras/source/templates/presnt/Focus.otp. It's an easy hack for a designer, not for a coder.
Comment 17 Jan Holesovsky 2015-12-16 10:36:35 UTC
Adding the keywords back based on comment 16 - I like the idea :-)  [Probably we need a separate bug for the EMF+ handling on OS X, but maybe that's already filed somewhere?]
Comment 18 Jan Holesovsky 2015-12-16 10:37:47 UTC
Direct link to download the template:

http://cgit.freedesktop.org/libreoffice/core/plain/extras/source/templates/presnt/Focus.otp
Comment 19 Robinson Tryon (qubit) 2016-02-18 14:52:04 UTC Comment hidden (obsolete)
Comment 20 steve -_- 2016-04-12 09:19:17 UTC
WORKSFORME

Version: 5.2.0.0.alpha0+
Build ID: 0a8abaadf322dca5628c6e62eb18b19394995c40
CPU Threads: 4; OS Version: Mac OS X 10.11.4; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-04-12_05:42:52
Locale: de-DE (de.UTF-8)