Download it now!
Bug 88292 - [Regression] FILEOPEN: Segfault when opening attached docx file
Summary: [Regression] FILEOPEN: Segfault when opening attached docx file
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2015-01-11 14:20 UTC by Thomas
Modified: 2015-12-15 11:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The problematic docx file (863.28 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-01-11 14:20 UTC, Thomas
Details
Backtrace (14.01 KB, text/plain)
2015-01-12 06:40 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas 2015-01-11 14:20:18 UTC
Created attachment 112091 [details]
The problematic docx file

Problem description: 
The attached file cannot be opened with Libreoffice 4.3.5.2.
Libreoffice simply crashes with a segfault.
Version 4.2.8.2 on the other hand opens it correctly (-> Regression).

I am using Arch Linux and libreoffice-fresh 4.3.5.

Steps to reproduce:
1. Try to open the attached file.

Current behavior:
Libreoffice segfaults, the file cannot be opened.

Expected behavior:
Libreoffice opens the files successfully.
Comment 1 Julien Nabet 2015-01-11 20:17:15 UTC
On pc Debian x86-64 with master sources updated yesterday, I don't reproduce the crash.
However, I could reproduce the crash with LO Debian package 4.3.3.
Since I don't have symbols with 4.3.3, I haven't retrieved a backtrace.
I'll try to find some time with 4.3 sources and 4.4 sources but it could take some time so if someone wants to give a try...
Comment 2 MM 2015-01-11 21:40:12 UTC
No problems with v4.4.0.2 under mint 17.1 x64. I can open the file normally.
Comment 3 Matthew Francis 2015-01-12 04:52:22 UTC
Source bisection from libreoffice-4-3-branch-point..libreoffice-4-3 points to the following commit. Checking now to see if there's any obvious follow-up on master.

commit bcbeac44ca54f41fb80a027214b9eb2ec1eb14dd
Author: Luke Deller <luke@deller.id.au>
Date:   Sat Jul 12 21:49:50 2014 +1000

    Copy first-header-footer test from ww8 to ooxml
    
    The test document was converted from doc to docx using MS Word 2010.
[...]
Comment 4 Matthew Francis 2015-01-12 06:40:33 UTC
Created attachment 112108 [details]
Backtrace

Backtrace from current 4.3 (80bbe4a4dcbb0286f472ca3ee0e21746995fe4a6)
Comment 5 Matthew Francis 2015-01-12 07:42:23 UTC
A follow-up reverse bibisect/source bisect points to the below as the missing fix from master:

commit 04fe5e6a31c9701177a744bbc8a53b2f664fe71c
Author: Miklos Vajna <vmiklos@collabora.co.uk>
Date:   Thu Sep 11 12:23:18 2014 +0200

    fdo#82114 RTF import: fix handling of first page in non-first section
    
    Change-Id: If06c6bcdda97447e6014223d997c7ff8abd64b48
Comment 6 Björn Michaelsen 2015-02-03 12:20:55 UTC
The commit in comment 5 has been released with 4.4.0 thus resolved/fixed. A possible backport to 4.3 is a different issue.
Comment 7 Robinson Tryon (qubit) 2015-12-15 11:03:44 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]