Bug 88328 - xlsx files dont save cell formats on blank cells
Summary: xlsx files dont save cell formats on blank cells
Status: RESOLVED DUPLICATE of bug 71897
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2015-01-12 14:30 UTC by jbrooks
Modified: 2015-12-15 11:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jbrooks 2015-01-12 14:30:08 UTC
Problem description: 
xlsx files dont save cell formatting on blank cells

Steps to reproduce:
1. create a new sheet
2. select all cells and set to text format
3. save file as xlsx then close calc
4. reopen the same file

Current behavior:
xlsx files: blank cells reset to general format

Expected behavior:
xlsx files: blank cells should save their formatting
Comment 1 raal 2015-01-13 20:23:20 UTC
I can confirm with Version: 4.5.0.0.alpha0+
Build ID: a272f5b7b30f356418ecf28eb95d066f081d1624
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-01-09_09:50:59
Comment 2 Buovjaga 2015-01-16 15:03:34 UTC
Format is not lost in 3.5.0. Either Office open XML or MS Excel 2007/2010 XML, same result. Regression.

Ubuntu 14.10 64-bit
LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 3 Rostislav 'R.Yu.' Okulov 2015-01-18 10:18:33 UTC
git bisect start
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
git bisect bad 423a84c4f7068853974887d98442bc2a2d0cc91b
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect good 65fd30f5cb4cdd37995a33420ed8273c0a29bf00
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect good 8f4aeaad2f65d656328a451154142bb82efa4327
# good: [9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02] source-hash-8600bc24bbc9029e92bea6102bff2921bc10b33e
git bisect good 9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02
# good: [8ad82bc1416a07501651e8d96fe268e47d3931d3] source-hash-13821254f88d2c5488fba9fe6393dcf4ae810db4
git bisect good 8ad82bc1416a07501651e8d96fe268e47d3931d3
# good: [d084d250b04446535ca1d7c29cf2062e6bd042b3] source-hash-688f72e3a2c3ef923389bbd21f6aea3afe1114db
git bisect good d084d250b04446535ca1d7c29cf2062e6bd042b3
# good: [c2069a369d738078124812312d51f21ea1ce2421] source-hash-f160e4935c474a5293b3d3c11b3d538efb4767a0
git bisect good c2069a369d738078124812312d51f21ea1ce2421
# bad: [a0f20bc04a32a7791ba765d2de2f44f1b74033d1] source-hash-1de66ba440855050a794b3b2a8647c1b02c210b8
git bisect bad a0f20bc04a32a7791ba765d2de2f44f1b74033d1
# bad: [10a508c66848944760e8ff2b4f76bd9c6da85c9e] source-hash-911186d98f06b43d4563b401244e2cc216b76f33
git bisect bad 10a508c66848944760e8ff2b4f76bd9c6da85c9e
# bad: [4143274a9dca036358581c74fbeb91ec9e246b1a] source-hash-f2321c529adf6d4a455742c30fb75fbe3f7efe02
git bisect bad 4143274a9dca036358581c74fbeb91ec9e246b1a
# good: [e818f97b99709bcedf56865e733647666cfae09c] source-hash-66e39940d763586060c4bcc8c3cd213495c40b79
git bisect good e818f97b99709bcedf56865e733647666cfae09c
# first bad commit: [4143274a9dca036358581c74fbeb91ec9e246b1a] source-hash-f2321c529adf6d4a455742c30fb75fbe3f7efe02

4143274a9dca036358581c74fbeb91ec9e246b1a is the first bad commit
commit 4143274a9dca036358581c74fbeb91ec9e246b1a
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Oct 17 07:28:27 2013 +0000

    source-hash-f2321c529adf6d4a455742c30fb75fbe3f7efe02
    
    commit f2321c529adf6d4a455742c30fb75fbe3f7efe02
    Author:     Jürgen Schmidt <jsc@apache.org>
    AuthorDate: Thu Dec 20 14:35:07 2012 +0000
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Thu May 23 09:45:52 2013 +0100
    
        Resolves: #i121522# remove nonexistent, never published extensions...
    
        from ExtensionDependencies
    
        (cherry picked from commit 3484496e57ab59b4f613d7c9f727b5945e17e5b4)
    
        Conflicts:
                officecfg/registry/data/org/openoffice/Office/ExtensionDependencies.xcu
    
        Change-Id: I1b2e7382837a4cfad667187a7f930ca54385c31e

:100644 100644 53818dd115409aba2cb8c46d98cb06c69412d9ca a387ff91c3848be8d8235a8b0a29b096f40f3d13 M      ccache.log
:100644 100644 3a78939d7d63cdf6030301a2146efb147b995e0e d0500a84fd70bb88043180bf56a26ae417a23717 M      commitmsg
:100644 100644 71e430639ffe015e5aa214e23e07da3c51de2333 6647aeb3429df04df5e2a942afd5f253dbae7829 M      dev-install.log
:100644 100644 e612bba29a2cbe23306349bb3dcaee825333c608 a4990d0024cbf11a17e00c2b9b3c773c159899e8 M      make.log
:040000 040000 a7ee6a82e726e255cbafa0ebcd782dfec2598797 6004b31ecdffff2b247e605b8ee72d5102dbbf49 M      opt
Comment 4 Matthew Francis 2015-01-18 13:59:19 UTC

*** This bug has been marked as a duplicate of bug 71897 ***
Comment 5 Robinson Tryon (qubit) 2015-12-15 11:03:04 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]